How to disable font subpixel rendering in IJ13?

Hello,

IJ13 looks very nice, but I think code was rendered much nicer in IJ11 than IJ13. And I suspect the reason is subpixel rendering. I can see weird colors in supposed black text, and letters also look a bit thinner than in IJ11, which looks less good imho.

Just to show an example how bad the subpixel font rendering is, in the following dropdown the text "DejaVu Sans Light" represents "black" text, but it looks more like a circus:

intellij13font.png

Is there a setting to disable subpixel font rendering?

Thanks!

2 comments
Comment actions Permalink

I found it! It worked by adding

-Dawt.useSystemAAFontSettings=false

to 'eval "$JDK/bin/java" ......' at the end of the idea.sh file.

false can be replaced by on, gasp, lcd, ... to find your best preference :) "gasp" looks the best imho: no weird colors, but also no graininess like "false" gives.

0
Comment actions Permalink

Better leave idea.sh itact and remove "-Dawt.useSystemAAFontSettings=true" line from idea[64].vmoptions file.

0

Please sign in to leave a comment.