Error highlighting frequently stops working in build #7782

I've been working on 7782 for a little while now and I've noticed that the editor highlighting seems to "freeze" fairly frequently.

What I mean by "freeze" is that, no matter what changes I make to the file the error highlighting no longer updates to reflect the changes I'm making ot the file.
Any errors that I fix remain hightlighted, and any errors that I introduce don't get highlighted.
This doesn't only affect the error highlighting itself - once I've fixed all errors in the build (according to Ctrl-F9/"Make Project") I can't commit to my CVS repository. I press Ctrl-K, add a commit comment and press Ok - IDEA just closes the commit dialog as if it worked (but it didn't commit anything).

I'm not getting any error or messages dialogs and there doesn't appear to be any error sbeing reported in the logs. ($HOME\.IntelliJIdea70\system\log)

I can only get error highlighting working again by restarting IDEA.
I can't reproduce the problem repeatedly, but I have a felling it happens more often when I have errors in a file that last for a while, say > 5 - 10 minutes (because I'm doing a resonably large refactor on this file).

Is anyone else having this issue with the latest build?

Is this an already known problem? I wouldn't want to raise a defect at the moment, becuase I can't reproduce the issue reliably, it's pretty intermittent (though happens at least once a day).

Also, does anyone know if I can "restart" the error highlighting without having to restart IDEA?

I have tried deleting all the cache files I could find in $HOME\.IntelliJIdea70\system, but it doesn't seem to help.

8 comments
Comment actions Permalink

Shorn Tolley wrote:

I've been working on 7782 for a little while now and I've noticed that the editor highlighting seems to "freeze" fairly frequently.

I've seen this once or twice.

N.

0
Comment actions Permalink

I'm getting this as well and restarting IDEA seems to be the only fix.

0
Comment actions Permalink

I get this mostly when opening Hibernate mapping files. I've only had it happen to me once on Java code. Closing the project and the reopening it (w/o restarting IDEA) seems to clear it up at least temporarily. It usually starts to happen again after a certain amount of time.

0
Comment actions Permalink

for me the error is unfixable. restart -> hightlighting broken withing seconds.

0
Comment actions Permalink

Yes, I've had this problem with Java code - also a related problem where the background code analysis 'freezes' (this with build 8280).

Edited by: Dave Lorde on Apr 13, 2008 12:21 AM

0
Comment actions Permalink

Tried out Diana #8280, the same problem happens in that build too.

Edited by: Shorn Tolley on Apr 15, 2008 11:04 AM

0

Please sign in to leave a comment.