0

Debugging Flex app doesn't hit breakpoints ?

Hi,

I'm having problems with debugging my Flex app. I get trace output but it doesn't hit breakpoints:
CropperCapture[1].png

Console output:
"c:\program files (x86)\jetbrains\intellij idea 12.1.6\jre\jre\bin\java.exe" -Dapplication.home=C:\bin\flex3 -Xmx384m -Dsun.io.useCanonCaches=false -Dfile.encoding=UTF-8 -Djava.awt.headless=true -Duser.language=en -Duser.region=en -Xmx512m -classpath "C:\Program Files (x86)\JetBrains\IntelliJ IDEA 12.1.6\plugins\flex\lib\idea-fdb-3-fix.jar;C:/bin/flex3/lib/fdb.jar" flex.tools.debugger.cli.DebugCLI
Adobe fdb (Flash Player Debugger) [build 9271]
Copyright (c) 2004-2007 Adobe, Inc. All rights reserved.
Waiting for Player to connect
Player connected; session starting.
[SWF] /swf/monkeywrench.swf - 4,851,375 bytes after decompression
[trace] here

I'm debugging in IE 10 and I have the debugger version of Flash:
CropperCapture[3].png

I'm compiling my Flex app using an ANT-skript:

<project name="monkeywrench-client" default="compile" basedir=".">

   <property file="local.build.properties"/>
   <property name="mxmlc.jar" location="${flex.sdk.dir}/lib/mxmlc.jar"/>

   <target name="init">
      <!--copydir src="assets" dest="${compile.assets.path}"/-->
   </target>

   <target name="compile" depends="init">
      <java
              jar="${mxmlc.jar}"
              fork="true"
              maxmemory="512m"
              failonerror="true">
         <arg value="+flexlib=${flex.sdk.dir}/frameworks"/>
         <arg line="-load-config+=flex-config.xml" />
         <arg line="-source-path ."/>
         <arg line="-services+=services-config.xml"/>
         <arg line="-library-path+=./lib/"/>
         <arg line="-output='${compile.swf.path}/${compile.swf.name}'"/>
      </java>
   </target>

</project>

With local.build.properties:

<flex-config xmlns="http://www.adobe.com/2006/flex-config">
    <compiler>

        <debug>true</debug>

        <keep-as3-metadata>
            <name>Form</name>
            <name>FormField</name>
        </keep-as3-metadata>

    </compiler>
    <file-specs>
        <path-element>Monkeywrench.mxml</path-element>
    </file-specs>
</flex-config>

What am I missing?

5 comments

Please sign in to leave a comment.