Debugging Flex app doesn't hit breakpoints ?


I'm having problems with debugging my Flex app. I get trace output but it doesn't hit breakpoints:

Console output:
"c:\program files (x86)\jetbrains\intellij idea 12.1.6\jre\jre\bin\java.exe" -Dapplication.home=C:\bin\flex3 -Xmx384m -Dfile.encoding=UTF-8 -Djava.awt.headless=true -Duser.language=en -Duser.region=en -Xmx512m -classpath "C:\Program Files (x86)\JetBrains\IntelliJ IDEA 12.1.6\plugins\flex\lib\idea-fdb-3-fix.jar;C:/bin/flex3/lib/fdb.jar"
Adobe fdb (Flash Player Debugger) [build 9271]
Copyright (c) 2004-2007 Adobe, Inc. All rights reserved.
Waiting for Player to connect
Player connected; session starting.
[SWF] /swf/monkeywrench.swf - 4,851,375 bytes after decompression
[trace] here

I'm debugging in IE 10 and I have the debugger version of Flash:

I'm compiling my Flex app using an ANT-skript:

<project name="monkeywrench-client" default="compile" basedir=".">

   <property file=""/>
   <property name="mxmlc.jar" location="${flex.sdk.dir}/lib/mxmlc.jar"/>

   <target name="init">
      <!--copydir src="assets" dest="${compile.assets.path}"/-->

   <target name="compile" depends="init">
         <arg value="+flexlib=${flex.sdk.dir}/frameworks"/>
         <arg line="-load-config+=flex-config.xml" />
         <arg line="-source-path ."/>
         <arg line="-services+=services-config.xml"/>
         <arg line="-library-path+=./lib/"/>
         <arg line="-output='${compile.swf.path}/${}'"/>



<flex-config xmlns="">




What am I missing?

Comment actions Permalink

Why don't you compile by the IDE?
Probably your project is not configured correctly because there's red code on the screenshot. If you need assistance in project setup please attach your .idea folder contents, *.iml file(s) zipped and briefly describe your project structure.

As far as I understand you need to use ancient Flex SDK 3.x for your project. Debugging should work better with debugger tool from more recent SDK. Luckily in IntelliJ IDEA you can use one SDK for code highlighting/compilation and another one for debugging. Please try following:
- download Adobe Flex SDK 4.6 or Apache Flex SDK 4.11 and install it on your computer
- configure this SDK in Project Structure | SDKs
- click Run | Edit Configurations... and select this 4.x SDK in the 'Use Debugger from SDK' field.

Comment actions Permalink

Hi Alexander,

I'm using an ANT build file to compile as I want to have full controll over the build process.

I've tried to install Flex sdk 4.11 and use that for debugging as you suggested but with the same result: console output works but no breakpoints.

I've attached my project setup files. It's a simplest one module project.


Comment actions Permalink

Thank you for the attachment.
Now I see that you didn't configure any source roots. Open File | Project Structure | Modules | [your module] and fix it.
You only have one content root configured (F:/Checkouts/Offerta/branches/blackwidow/Source/Monkeywrench.Flex/flex), and no source folders at all.
I guess that module root folder (where dev_blackwidow.iml file located) should be a content root, and its src subfolder should be a source folder.
I don't know what is there in F:/Checkouts/Offerta/branches/blackwidow/Source/Monkeywrench.Flex/flex, may be it shoud be a content root with src source folder, may be - not.

Then to get code referring 3rd party libraries green see how to configure dependencies:

Comment actions Permalink

Looking a bit more at your project files I see that you keep source files directly in the project root dir, without src subfolder. That's not very good decision, but if you do not want to change it now you can configure project root folder both as a content root and as a source folder. The same about F:/Checkouts/Offerta/branches/blackwidow/Source/Monkeywrench.Flex/flex: it seems to be both content root and a source folder.

When you configure source folder breakpoints will work, both with debugger from Flex SDK 3 and 4.

Comment actions Permalink

Thanks that did the trick!


Please sign in to leave a comment.