8 comments

On 2007-10-16 02:28:47 +0400, Michael Besosa <mbesosa@visi.com> said:


I just downloaded IDEA 7.0 for Mac OS X. Previously, I'd been using
7348 without problems. When I try to run 7.0, with my 6.0 license in
place, I get an alert saying that I have to upgrade. If I click OK,
IDEA sits there apparently doing nothing but consuming about 100% of a
CPU. If I look in the log directory, there is an idea.log file, and
also an idea.log.1, idea.log.2, etc. Furthermore, I can see that
numbered log files are being continuously created and destroyed.
Attached is the idea.log file. The numbered logs appear to contain the
same sort of entries. Perhaps these files are being rolled by log4j
when they reach a certain size (looks like 1MB)?

I never see the usual request for my administrative password, and IDEA
never enters a usable state. However, 7348 still works.


This message has one or more attachments. Select "Save Attachments"
from the File menu to save.
2007-10-15 17:24:11,993 ERROR -
llij.ide.plugins.PluginManager - JDK: 1.5.0_07 2007-10-15 17:24:11,993
ERROR - llij.ide.plugins.PluginManager - VM: Java
HotSpot(TM) Client VM


I cannot download the log file, could you please send it to
kirill.kalishev@jetbrains.com

--
Kirill Kalishev
JetBrains, Inc.
http://jetbrains.com
"Develop with pleasure!"

0

On 2007-10-16 02:28:47 +0400, Michael Besosa <mbesosa@visi.com> said:


I just downloaded IDEA 7.0 for Mac OS X. Previously, I'd been using 7348
without problems. When I try to run 7.0, with my 6.0 license in place, I
get an alert saying that I have to upgrade. If I click OK, IDEA sits
there apparently doing nothing but consuming about 100% of a CPU. If I
look in the log directory, there is an idea.log file, and also an
idea.log.1, idea.log.2, etc. Furthermore, I can see that numbered log
files are being continuously created and destroyed. Attached is the
idea.log file. The numbered logs appear to contain the same sort of
entries. Perhaps these files are being rolled by log4j when they reach a
certain size (looks like 1MB)?

I never see the usual request for my administrative password, and IDEA
never enters a usable state. However, 7348 still works.


This message has one or more attachments. Select "Save Attachments"
from the File menu to save.
2007-10-15 17:24:11,993 ERROR -
llij.ide.plugins.PluginManager - JDK: 1.5.0_07
2007-10-15 17:24:11,993 ERROR -
llij.ide.plugins.PluginManager - VM: Java HotSpot(TM) Client VM


Please check if your %IDEA_INSTALLATION_HOME%\bin path contains
idea.properties file.

0

I am having the exact same issue. Only it is on Windows XP. I currently have a fully licensed Intellij 6.0 installed on my machine. I did not uninstall 6.0.

I downloaded intellij 7.0 and installed it. During the initial configuration it asked if I wanted to import my settings from a previous release. I pointed it at my intellij 6.0 home directory. It then informed me that I need to upgrade (I had hoped to eval 7.0 for 30 days while I wait for our IT department to get the upgrade licenses). All I can do is click 'OK'. There is never a screen or option to enter an upgrade key. Sometimes after clicking 'OK' intellij just stops. Sometimes the process remains and consumes 100% of the CPU.

I do have a idea.properties file in my bin directory. I have also tried reinstalling, but on the subsequent install, it never even gets to the point of asking if I want to import my settings, I just get the "You need a license" popup. I have attached the logs.

Thank you for your assistance,



Attachment(s):
log.zip
0

Hello Adam,

I am having the exact same issue. Only it is on Windows XP. I
currently have a fully licensed Intellij 6.0 installed on my machine.
I did not uninstall 6.0.

I downloaded intellij 7.0 and installed it. During the initial
configuration it asked if I wanted to import my settings from a
previous release. I pointed it at my intellij 6.0 home directory. It
then informed me that I need to upgrade (I had hoped to eval 7.0 for
30 days while I wait for our IT department to get the upgrade
licenses). All I can do is click 'OK'. There is never a screen or
option to enter an upgrade key. Sometimes after clicking 'OK'
intellij just stops. Sometimes the process remains and consumes 100%
of the CPU.

I do have a idea.properties file in my bin directory. I have also
tried reinstalling, but on the subsequent install, it never even gets
to the point of asking if I want to import my settings, I just get the
"You need a license" popup. I have attached the logs.


Could you please edit the file bin\idea.properties under the installation
directory and comment out the following line:
idea.fatal.error.notification=disabled

Then please try to start IDEA again, and if it doesn't start, post the logs
here or e-mail them to me.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Well...I had uninstalled (deleting the idea home, and the idea directory under documents and settings). Upon reinstallation, I am able to start and use idea fine. I cant think of anything different that occured on the second installation.

0

I just tried this, too. There is an idea.properties file in the expected
location. I commented out the notification line. Again, IDEA failed to
launch completely, but this time it did not flood the log continuously,
consumed no CPU cycles and was not reported hung by OS X. I was able to
exit the program by selecting Quit from the application menu. The full
content of the log after the hang is at the bottom of this message.

You'll remember that I'm experiencing this problem on OS X, so my
installation scenario is simpler. My Selena 7348 and my 7.0 bundles are
in /Applications and all important directories (system, config, etc.)
are in their default locations. After 7.0 failed to launch the first
time, I tried the usual things (deleted my plug-ins, deleted the
contents of system, moved the last project I had opened in case there
was something wrong with it, and so on) without effect.

Here's the log:

2007-10-16 17:05:38,668 INFO -
#com.intellij.idea.Main -
-


IDEA STARTED
-


2007-10-16 17:06:08,374 ERROR -
llij.ide.plugins.PluginManager - Error while accessing
com.intellij.idea.MainImpl.start with arguments: []
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at com.intellij.ide.plugins.PluginManager$4.run(PluginManager.java:434)
at java.lang.Thread.run(Thread.java:613)
Caused by: java.lang.IllegalArgumentException: Validation failed
at
com.jetbrains.licenseServer.openapi.util.ClientUtil.a(ClientUtil.java:56)
at
com.jetbrains.licenseServer.openapi.util.ClientUtil.executeRpc(ClientUtil.java:58)
at
com.jetbrains.licenseServer.openapi.util.ClientUtil.executeRpc(ClientUtil.java:32)
at
com.jetbrains.licenseServer.openapi.util.ClientUtil.ping(ClientUtil.java:9)
at com.intellij.ide.a.c.j.a(j.java:154)
at com.intellij.ide.a.c.j.access$400(j.java:70)
at com.intellij.ide.a.c.j$m_.a(j$m_.java:2)
at com.intellij.ide.a.c.j.a(j.java:10)
at com.intellij.idea.MainImpl._main(MainImpl.java:63)
at com.intellij.idea.MainImpl.start(MainImpl.java:16)
... 6 more
2007-10-16 17:06:08,376 ERROR -
llij.ide.plugins.PluginManager - JDK: 1.5.0_07
2007-10-16 17:06:08,377 ERROR -
llij.ide.plugins.PluginManager - VM: Java HotSpot(TM) Client VM
2007-10-16 17:06:08,377 ERROR -
llij.ide.plugins.PluginManager - Vendor: Apple Computer, Inc.
2007-10-16 17:06:08,377 ERROR -
llij.ide.plugins.PluginManager - OS: Mac OS X
2007-10-16 17:06:08,377 ERROR -
llij.ide.plugins.PluginManager - Original exception:
java.lang.IllegalArgumentException: Validation failed
at
com.jetbrains.licenseServer.openapi.util.ClientUtil.a(ClientUtil.java:56)
at
com.jetbrains.licenseServer.openapi.util.ClientUtil.executeRpc(ClientUtil.java:58)
at
com.jetbrains.licenseServer.openapi.util.ClientUtil.executeRpc(ClientUtil.java:32)
at
com.jetbrains.licenseServer.openapi.util.ClientUtil.ping(ClientUtil.java:9)
at com.intellij.ide.a.c.j.a(j.java:154)
at com.intellij.ide.a.c.j.access$400(j.java:70)
at com.intellij.ide.a.c.j$m_.a(j$m_.java:2)
at com.intellij.ide.a.c.j.a(j.java:10)
at com.intellij.idea.MainImpl._main(MainImpl.java:63)
at com.intellij.idea.MainImpl.start(MainImpl.java:16)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at com.intellij.ide.plugins.PluginManager$4.run(PluginManager.java:434)
at java.lang.Thread.run(Thread.java:613)
2007-10-16 17:06:08,378 ERROR -
llij.ide.plugins.PluginManager -
java.lang.NullPointerException
at
com.intellij.diagnostic.DialogAppender.appendToLoggers(DialogAppender.java:22)
at com.intellij.diagnostic.DialogAppender$1.run(DialogAppender.java:9)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
2007-10-16 17:06:08,378 ERROR -
llij.ide.plugins.PluginManager - JDK: 1.5.0_07
2007-10-16 17:06:08,378 ERROR -
llij.ide.plugins.PluginManager - VM: Java HotSpot(TM) Client VM
2007-10-16 17:06:08,378 ERROR -
llij.ide.plugins.PluginManager - Vendor: Apple Computer, Inc.
2007-10-16 17:06:08,379 ERROR -
llij.ide.plugins.PluginManager - OS: Mac OS X

0

Ok, thanks a lot.
The workaround would be adding oldlicenseserver=true line to idea.properties.

0

Maxim Shafirov wrote:

Ok, thanks a lot.
The workaround would be adding oldlicenseserver=true line to idea.properties.


That works! Thank you.

0

Please sign in to leave a comment.