Idea 12 and weblogic 12c not working

Hi all,
I just downloaded latest IDEA (12) and found out that I cannot use weblogic 12c as an application server.
I'm using the following Weblogic Home: c:\wls12120.
All I can see is: Warning: The selected directory is not a valid WebLogic home.

I've also tried c:\wls12120\wlserver, but still the same message.

The documentation that I could find sucks big time and I could not find any blogs related to this issue.
I've got a valid weblogic 12c installation that Eclipse of Netbeans can work with, so I don't understand what's the issue with IDEA.

Attached are screenshots.

Comment actions Permalink

I just tried also with IDEA 13 preview version and it's the same.
I'm really amazed that such basic enterprise feature is not working and no one noticed....?:|

Comment actions Permalink


Well, *someone* has noticed that in July, see
IDEA-12 is not expected to support the 12-1-2 for reasons described in this comment: IDEA-110430

In the latest 13-EAP the enterprise edition of WL 12-1-2 (the one installed using Weblogic distribution with installer wls_121200.jar) should be supported out of the box.
There are still some problems with developer edition (the one installed from zip distribution, your names suggests that it is your case).
Details and possible workaround for the latter is described at this comment:

The problem with dev edition is to be fixed next 13-EAP.

Comment actions Permalink

In case you don't want to wait for IDEA 13 EAP, here's a workaround for IDEA 12 and 13 preview.

Install Weblogic version 10.3 and copy registry.xml from 10.3 to 12c weblogic home (dev or full version, doesn't matter).

Don't forget to modify path and version in this registry.xml file.

For lazy ones: Use the attached registry.xml and modify it according to your needs.


Please sign in to leave a comment.