Keyboard layout problem

Hi,

I use IntelliJ IDEA (12) on a Macbook Pro with the "Mac OS X 10.5+" keymap. I have a belgian keyboard layout.
Some of the shortcuts don't work as expected. For example, the shortcut for commenting code (cmd + /) folds the code instead, which should be (cmd + =).
When trying to change the shortcut for commenting code to effectively be "cmd + /", the IDE tells me I have in fact typed "shift + cmd + ."

So it seems IntelliJ IDEA have the wrong keyboard layout.

I've looked into the settings but found nothing related to that "problem".

Is there a way to make IntelliJ IDEA use the right keyboard layout ?

Regards

1 comment

I'm not a Mac user and I use a US Keyboard, so I cant speak directly to your problem. But I have seen some threads previously about issues with Macs and certain keyboards. Here's a few:


I hope that helps.

0

Please sign in to leave a comment.