launching chrome incognito in intellij 12

Hi
I have a JavaScript Debug configuration that launches a chrome browser
I need it to run incognito
please help.
Thanks.

5 comments

http://youtrack.jetbrains.com/issue/WEB-4404
1) open Google Chrome Extensions page chrome://extensions/ and check "Allow in incognito" flag for JetBrains Chrome Extension.
2) open IDE settings: Settings ->  Web browsers -> Chrome -> Settings... -> Command line options: --incognito

Pitfall: If Chrome is already running not in the incognito mode, new instance will not be opened — exising will be used, so, incognito option will be ignored.

It seems, your want option "Run in the incognito tab" in the JS Debug run configuration. Could you please explain reasons?

1

Hi.
great it works.
Its Ok like this although yes it would be better if I could select chrome options for each run configuration seperately .
For example , currently our application has cache issues and to avoid them right now I prefer to run incognito.
but if I am running a different application I might not want this.
But for now this is Ok for me ,



Thanks. for the help.

BTW why must I do it in both the ide and the chrome extension , should Ide be enough .

0

>> BTW why must I do it in both the ide and the chrome extension , should Ide be enough .
You, as user, can allow or disallow extension to work in incognote mode. Extension cannot manage it due to security reasons.

0

My dear fellow developers,

 

First of all greeting from Croatia, it's my first post here so I thought I can't find a better way then start my message with this... :)

Now back to the topic.

I just have enlightenment on this so I am sharing. I run Windows 10 x64 and have CentOS7 as Virtual Machine over at Sun Virtual Box. With PhpStorm:

PhpStorm 2017.2.4
Build #PS-172.4155.41, built on September 15, 2017
Licensed to eSolutions d.o.o. / Matija Baric
Subscription is active until May 3, 2018
JRE: 1.8.0_152-release-915-b11 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0

This is really an easy thing to setup actually and it comes natural.

1. Start chrome in incognito mode, by right clicking with your mose on chrome icon or by running chrome -incognito in the terminal (of course if your path is setup right). (https://i.imgur.com/oS0FdCI.png)

2. In PhpStorm you setup your normal settings:

Server: https://i.imgur.com/nKLF8c7.png

Run/debug configuration: https://i.imgur.com/0K5mjzN.png

Web browsers: https://i.imgur.com/jKByXhg.png

Then just run your debugging (https://i.imgur.com/tZKs9gA.png) and wholla phpstrom will run in firstly opened Incognito.(https://i.imgur.com/Ac4a9Qg.png)

Best of luck I hope it helps somebody. give me a thumbs up if it works for you too please.

 

Little bit about me :)

https://www.upwork.com/freelancers/~01849f2dcb6801a8f8?viewMode=1

https://stackoverflow.com/story/matijabaric

https://stackoverflow.com/users/779965/matija

https://twitter.com/1Crodev

https://github.com/mbaric

https://bitbucket.org/matbaric/

0

While working in incognito mode I have faced a lot of issues. The issues were majorly a confirmation error. Like after the last update of chrome I have seen that there is a lot of problems in confirmation form resubmission and turn off confirm form resubmission, etc. It can be the major issues faced by someone while using chrome. Then I browse regarding how to turn off confirm form resubmission chrome, and got some genuine solutions. If you feel the same, you can also browse.

0

Please sign in to leave a comment.