Upgrade to 12.1.4


I have an ultimate licence and am upgrading mt IntelliJ to 12.1.4.
I uninstalled all the previous versions but did not delete my plugins, cache etc

However, in the installation progress when I selected the folder of a previous installation, it said it couldn't find any configurations files there. So I just went with the other option to start from scratch, put in my licence.

I can see in my folder for IDEA 12.0.4 a bin folder and a lib folder but not too sure how I can use that to get all my projects etc back to how they were before the upgrade into this new version.
And when I try rto Import my exsiting projects and select my .iml file, I'm getting an error saying Cannot import anything from C:/project path.iml.

If anyone can help please! :-(
Not sure what to do.

Comment actions Permalink

You should do the following:

  • make sure that plugins, configs and caches of the previous installation really exist on your computer. Most likeky all these are stored in the folder {user.home}/.IntelliJIdea11, where {user.home} on Windows is usually C:/users/{your name}.
  • make sure that IntelliJ IDEA is not running
  • delete (or rename) the folder {user.home}/.IntelliJIdea12
  • start IntelliJ IDEA, select to import settings from previous version and select the following folder: {user.home}/.IntelliJIdea11/config.

.IntelliJIdea12 folder will be created again and all your settings should be imported.

Comment actions Permalink

Hi Alexander

I only have the one C:/Users/.IntelliJIdea12.
I tried to Configure/Import Settings and selected the /config dir but it couldn't find the settings.jar :/


Comment actions Permalink

I only have the one C:/Users/.IntelliJIdea12.

That means that you don't have configuration, plugins and caches of the previous IntelliJ IDEA installations. Don't worry, you lost not that much:
- configured SDKs
- configured Global Libraries
- list of the recent projects
- global custom settings like colors&fonts,code completion settings and thousand more, but most probably you worked with most of them set to default
- installed 3rd-party plugins

So just open manually the project(s) that you work with (File | Open..., select project folder (not iml file!)), open Project Structure and fix error detected there because of not-configured SDKs and Global Libs).

Comment actions Permalink

Ah ok thanks!
Piecing it all back together.

I think what happened was I thought I'd clean up all the settings, plugins for previous versions 12.0.2 and 12.0.4 not realising that they all fall under and are shared under the same version 12?

Comment actions Permalink

Sorry, I didn't notice that you upgrade from 12.0.4 and thought you upgrade from 11.x.
Yes, all versions of IntelliJ IDEA 12.x by default store all global settings/plugins/caches in the same folders. In future if you'd like to have several installations of the same major version in parallel - you need to set custom values to the following properties in each {IntelliJ DEA installation}/bin/idea.properties file:


Comment actions Permalink

Sorry probably should have mentioned.

Right, note taken for next time!
Is there by any chance a file somewhere that might be lingering on my desktop that I could reference to remember all my dependencies, compiler options etc

Comment actions Permalink

I'm not sure I got the question.
All dependencies, compile options, etc. are stored per project and you didn't loose any configured project. You lost only global things like SDKs - that's easy to reconfigure.

Comment actions Permalink

You're right. I see now :)
It didn't pick up the correct .iml which was renamed to something else (not matching the project/folder name)


Please sign in to leave a comment.