Debugger not working in Intellij 11.1.5

Hello,

I've got an iMac 64bits and I'm working with ruby/cucumber & using Intellij 11.1.5 with jruby 1.6.8 (and I've tried with ruby 1.9.3 as well) but when I try to launch the debugger I just get the following error:

Cannot connect to the debugged process at port 60311 in 10s:


Dumping and destroying process, when the debuggee process is running. You might try to increase the timeout. Killing...


Error Output:

Fast Debugger (ruby-debug-ide 0.4.17, ruby-debug-base 0.10.3.2) listens on 127.0.0.1:60311


Please try increasing timeout in Settings | Debugger | Ruby | Debug connection timeout

I've tried the following without success:

  • increase the timeout to 30secs
  • reinstall ruby-debug-ide, ruby-debug-base, ruby-debug
  • gem install linecache
  • sudo env ARCHFLAGS="-arch x86_64" gem install linecache


Still, I am unable to launch the debugger. Any idea what could be the problem and how I could get it fixed?

Thank you...

1 comment

Please check that you have hostname specified in System Preferences | Sharing | Computer name.

0

Please sign in to leave a comment.