Turn off Wildcard imports?

Is there a way to turn off wildcard import like "import javax.persistence.*;" ?

Intellij 12.1.4 usually imports exactly the class I need, for example:

import javax.persistence.Entity;
import javax.persistence.GeneratedValue;
import javax.persistence.Table;



But at some point it replaces all the individual import statements with:


import javax.persistence.*;


Is this behavior controlled by a setting anywhere?
2 comments

File > Settings > Project Settings > Code Style > Java > Imports > General > Class count to use import with '*'

In The settings dialog you can also search/filter - see field in the top left.

2

Thanks, that's exactly what I needed!

0

Please sign in to leave a comment.