Too Many Tooltips!

Answered

Hi,

I love IDEA, but the plethora of tooltips drives me a bit crazy.

E.g., tool-tips that show me my ToDo comments, when those comments are already distinctly highlighted and fully visible in the editor pane, are completely gratuitous. The tooltips showing full path names on editor tabs are not something I need and frequently intercept clicks that I intend to bring up the tab's context menu.

Is there, by any chance, a means to turn at least some of the tooltips off that I've overlooked all these years?


Randall Schulz

12 comments

Hi Randal,

AFAIK there is no such an ability.

The only option is to reduce initial tooltip delay at ide settings | appearance | tooltip initial delay

Denis

0

Denis,

I already have it at the max allowed: 1200.

(Might I edit an internal file to exceed the limit imposed by the Settings GUI?)

0

Yes, it's possible to set a greater value:

  1. Call 'Maintenance' action (Ctrl+Alt+Shift+/ at default keymap);
  2. Choose 'Registry';
  3. Set target delay value for 'ide.tooltip.initialDelay' property;
  4. Restart the ide;

Denis

0

What would the keyboard binding for that be on a Mac? No variation on modifiers with the '/' key do anything for me (other than the usual commenting bindings). Is there a menu item for this action?

Also, I notice that while I have tool-tip delay set to 1200 milliseconds, it is clearly not waiting anywhere near that long to bring up tool-tips.

0

Not sure about Mac shortcut but you can always invoke it using the approach below:

  1. Click main menu | help | find action;
  2. Type 'Maintenance';
  3. Press <enter> when the action item appears;


Denis

0

Denis,

Thanks for the information. I guess I did something wrong, 'cause Cmd+Option+Shift-/ does indeed bring up the little selector bar. (It's possible I missed it before since it opens centered on the active editor, not on the center of the screen, and is small and just the "Maintenance" title and two rows of text.) Anyway...

I used the Registry mainenance dialog to set ide.tooltip.initialDelay to 5000 (it became bold, presumably indicating it had been altered) and restarted IDEA.

This setting does not appear to control all the tooltips. It clearly affects the full path-name tool-tip on the editor tabs but not, e.g., the TODO tool-tips.

0

The tooltips are a great help but they do show too quickly for me. All the on-screen flashing as I move my mouse breaks my concentration. I tried increasing ide.tooltip.initialDelay but it didn't slow down the appearance of the tooltips. They still appear almost instantly. I'm on Mac also.

1

I'm with you @Tedhenry100.  It drives me bananas.  Shall we turn this into a feature request?

0

that setting isn't honored.  Set it to 0, 1200, or 12000 in the xml, makes no difference.

0

Any chance any of those issues might be addressed within my lifetime?

0

Hello. Unfortunately there is no ETA at the moment, voting should help prioritize the issues.

0

Please sign in to leave a comment.