Gutter Outline for Matching Braces

http://www.jetbrains.com/idea/webhelp/highlighting-braces.html

As indicated in the, seemingly current, help page above, when one had their cursor at a brace in the editor, there used to be an outline in the gutter area which would indicate the scope matching brace (beginning or end). I no longer see this. Was this removed (I hope not) or is there an option I need to check in the settingssomewhere to re-enable this?

Matt

3 comments

Settings > [IDE Settings] > Editor
In the "Highlight on Caret Movement" section (middle right), check the option "Highlight matched brace"

0

This just highlights the brace (and was already checked in my config). It does not enable the gutter outline.

After some experimentation, it sems that this issue is related to the Darcula scheme. Using the normal theme, the gutter outline does appear.

On a side not, I'm having a ton of trouble with the color schemes. Nothing changes after switching a theme until i restart the IDe and even then, only the editor section changes with the rest of the IDE remaining in the Darcula color theme even after switching to default. Frustrating.

0

watter wrote:
 
On a side not, I'm having a ton of trouble with the color schemes. Nothing changes after switching a theme until i restart the IDe and even then, only the editor section changes with the rest of the IDE remaining in the Darcula color theme even after switching to default. Frustrating.

Never mind on this part. I'm dumb. There are two different scheme setting; one for ther editor and one for the rest of the IDE. I wa only changing the editor one, hence why the rest fo the IDE remained in Darcula. I'd still like to find a way to see the scope gutter outline while using the Darcula scheme.

0

Please sign in to leave a comment.