Typescript Bug ? Importing Typescript Files > Not Watched Not Transpiled

Idea 12.1, XP

I have just copied about 20 .ts files into a project through Explorer, and these are not Watched in Idea ... and they are not transpiled into .js.

In Idea if I right-click and ADD NEW TYPESCRIPT FILE, then it IS Watched and Transpiled.


But not if I copy a .ts file into the project.

I have tried dragging the .ts files onto the project window in Idea > nothing happens.

I have tried editing some xml files in the ".idea" project folder to add the files ... nothing happens.



I have about 100 .ts files to add into this project ... is there a way to do it ?  Without right-click add new, copy and paste then contents etc... ?

thanks

2 comments

Hello,

Please provide a screenshot of your 'project settings | file watchers' settings.

Denis

0

Sorry ... my mistake ... looks like the

///<references line

... at the top was point to the wrong file and so preventing transpiling.

(praise the Lord)

0

Please sign in to leave a comment.