check out from VCS - source files not found

Hi,

I have a problem getting creating a php project from BitBucket.

I chose 'Check out from Version Control' in the main IntelliJ screen. I connect to BitBucket, select my repo and the files and directories are read into the destination. Then, I get a screen that asks me if I want to create a project from the existing sources. I answer 'Yes' and select the directory under which the BitBucket files are stored in several subdirectories. But no project is created, instead I get a message "Source files for your project not found". Nvertheless, a Idea project is created and opened in the IDE, but without files. The structure on disk looks the same as with other projects.
I also tried "Import Project" from the File menu in the new project, I chose to overwrite the project files but got the same error.

I have tried this several times on a Windows system as well as on Linux.

I use IntelliJ 12.1.4 build 129.713.

How can I get the files in the project?

Chris

3 comments

Hi,

Now I tried a different approach. I checked out the project but did not create a project right away. I closed the IDEA, restarted it and chose 'Create new project', Web Module' and now the files where read into the new project. It was connected to BitBucket as well.

Is this the way it should be done??

Chris

0

Hi Chris,

I see that there are two possible cases here:

  • there is a bug at the ide;
  • you did something wrong;


Could you provide the following:

  • a screencast which illustrates your actions;
  • resulting invalid project;
  • information about your bibucket project (will try to reproduce that at local environment as well);

Denis

0

Hi Denis,

Attached some screenprints and the requested information.

Regards,

Chris



Attachment(s):
IntelliJ IDEA checkout problem.odt
0

Please sign in to leave a comment.