Relaxing Ruby plugin's gem version matching

I have a Ruby on Rails project. Its Gemfile defines a gem with a specific version. This version is slightly different from the version I have installed on the local machine. This works because I never run the project on the same machine as IDEA; the files are mounted from another server. So, IDEA sees somegem-0.8.1 while my project's Gemfile requires somegem-0.8.1.1. This is a problem for me because IDEA refuses to recognize the gem due to the slightly different version, and it highlights a bunch of code as unrecognized.

Because I am not able to simply do a 'gem install somegem --version 0.8.1.1' on the same machine as IDEA, I would like to relax IDEA's version matching, either for just that gem or for all gems. I'd like to say, in effect, "As long as I have somegem-0.8.x.x installed, fulfill the dependency on somegem-0.8.1.1." Is this possible?
------

Some background: version 0.8.1 is the latest public version of this gem. Version 0.8.1.1 is a private version that fixes some issues, but we have not yet contributed the changes upstream.

1 comment

Hi,

if your Gemfile requires exact gem's verion then Ruby plugin requires it too and there is no way to configure plugin to allow other versions :(
But you always can change your Gemfile to allow such versions.  E.g. "~>0.8.1" allows any 0.8.x.x.

Hope this helps, Oleg.

0

Please sign in to leave a comment.