Upgraded to 12.1.4 and now "java: javacTask: source release 1.7 requires target release 1.7"

Hello,

I just upgraded this morning to 12.1.4 and now projects that have been working for months will no longer compile.  The problem is "java: javacTask: source release 1.7 requires target release 1.7".  I've googled this and found that I have nothing under File/Settings/Compiler/Java Compiler/Additional command line parameters, it is blank.  Also, adding a "-target 1.7" or a "-source 1.7 -target 1.7" does nothing to rid the problem.

Any suggestions, please?

Thanks

2 comments

Solved my own problem,

I closed the new intellij (12.1.4) and opened an older one (12.0.4), after it re-indexed the project it pointed me to a <> empty diamond that is only JAva 1.7+ and told me that my project was 1.6.  The usual Alt-Enter lead me to Project settings and I switch to top pom.xml to Java 1.7.  After this worked I was able to go back to the newer version of intellij.

Yo

0

This type of thing happens constantly on upgrade.  I upgraded this morning, and I am now spending hours trying to figure out why a project that DID compile before the upgrade now says "Error:java: javacTask: source release 1.8 requires target release 1.8".

No code change at all.   Just an 'up'grade.  This has happened on so many versions of Intellij that I almost always refuse the upgrades.  This mrning I was not paying enough attention.

This is incredibly frustrating and costs me enormous amounts of time.  I would really appreciate it if there was SOME indication as to what project/file/setting/black magic was causing this to happen repeatedly.

0

Please sign in to leave a comment.