Control-N (open class) not finding classes

All,

I have a problem with an Idea 11.x project where control-n doesn't show all matching classes.  I've been using Idea for 10 years and generally know what I'm doing but am pretty stumped on this one.

I created a project from existing src.  I've done it two ways.  By default, Idea wants to create separate modules for the src and test trees.  Control-n doesn't find any of the src code, only test.  If I recreate the project with a single module containing src and test, marked appropriately under the modules/sources tab, I still get the same behavior where the src classes are not found, only test classes.  If I open a src class by clicking it in the project browser, I get errors about classes and imports not being found, even though they're right where they should be.

Currently I'm having this problem with an internal codebase, but I think I once had it with Axis 1.x, fwiw.

Any suggestions?

Thanks

john

3 comments

Hi John,

Please try to execute main menu | file | invalidate caches

Denis

0

Worked perfectly.  Thanks.

0

Please sign in to leave a comment.