Hiding Noise in Project View

Hi,

When we are managing all files using the Project View, there is a lot of noise there, like .idea, .idea_modules, target, project, "External Libraries", etc. I tried the Packages View also, but that flattens everything and you loose the location info for configiration files, etc.

With eclipse, there was an option to filter out some unnecessary stuff from this view, i.e. you could say do not show anything that starts with .idea*

Do we a similar option on IntelliJ?

Thanks...

4 comments
Comment actions Permalink

Hi Kobari,

You can configure a custom scope and use it at the project view.

Denis

0
Comment actions Permalink

Ah, awesome! But, one annoying issue:

When I select Project Scope, It shows "PROJECT_NAME" as the top level node, and child nodes are folders / files within that project.

But, When I create a new scope, e.g. MyProject and select it, there is "PROJECT_NAME" as the top level node, but one level below that is "PROJECT_NAME" again, then you see the project files? Basically, there are two levels with the same name?

Edit: Looking at the docs, second level seems to be a package? Why do we need both, can I not get rid of one, this looks really annoying...



Attachment(s):
Screen Shot 2013-05-29 at 8.27.52 PM.png
0
Comment actions Permalink

The top level node module.png is not actually the project's name, but is the module's name (File > Project Structure > [Modules] > "Name").  There is only a duplication if the module name is the same as the top level directory name. And even then, it is not really a duplication. It shows, in your case, the directory directory.png "todolist" as the top level directory in the module module.png "todolist". It's just that they have the same name. In a situation where they do not have the same name, the distinction is important.It would also be important if a module had multiple top level directories, or two modules had identially named top level directories.

That said, for a situation like yours where the not showing the module names would not muddle the hierarchy, you can turn off the modules in the display. Click the gear icon config-tool-window.png in the upper right border of the project tool window and uncheck the "Show Modules" option.

0
Comment actions Permalink

HI Mark,

Thanks for the explanation. But, when I am in the project scope (regular project view), it only shows the Module Name, not the top level directory? Can I not have the same thing here as well? I mean, why does it not show that top directory in Project scope? What I want is this behavior actually.

I tried unselecting "Show Modules", but this time, it is showing another top-level node, that is: "project" (image attached). Where did that come from? This "project" folder is actually inside my module top level folder (todolist/proejct)? But, it is showing as a top-level node here?

Thanks.



Attachment(s):
Screen Shot 2013-05-30 at 12.33.29 AM.png
0

Please sign in to leave a comment.