Xml Schema problem

Hi there,
I am making two schemas that depend on each other. One main schema and one little extra schema. In my instance document I am using the main schema but I am getting some errors from IDEA. Could anyone please have a look to see if I am doing something wrong or if IDEA is to blame.

I am attaching the 3 files.



Attachment(s):
Document.xml
BookSchema.xsd
ExtraSchema.xsd
2 comments
Comment actions Permalink

I managed to fix it myself.
It seems that an import statement must be present in both schemas. E.g.

<xs:import namespace="http://www.jl.com/SubSchema"
schemaLocation="SubSchema.xsd"

0
Comment actions Permalink

Generally, one need to invoke -Validate- on xml and see errors that
caused by wrong schema

Johan Lund wrote:

Hi there,
I am making two schemas that depend on each other. One main schema and one little extra schema. In my instance document I am using the main schema but I am getting some errors from IDEA. Could anyone please have a look to see if I am doing something wrong or if IDEA is to blame.

I am attaching the 3 files.


------------------------------------------------------------------------

<?xml version="1.0"?>
<Library xmlns="http://www.bindows.net/BookSchema">
<book id="3">
<isbn>
1234
</isbn>
<bookextrastuff>
<hola>acd</hola>
<hola>efg</hola>
</bookextrastuff>
</book>
</Library>



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

Please sign in to leave a comment.