Changing config directory not working

I have separate logical drives for system stuff and development, and I want my Intellij settings and such to be on my development drive.  According to every search I've tried, I should just need to adjust the idea.properties file.
I went into idea.properties and uncommented/modified (what I thought were) the appropriate properties:

idea.config.path=D:/configs/.IntelliJIdea12/config

idea.system.path=D:/configs/.IntelliJIdea12/system
idea.plugins.path=D:/configs/.IntelliJIdea12/config/plugins
idea.log.path=D:/configs/.IntelliJIdea12/system/log



I then copied the .IntellijIdea12 folder from it's location in C:\Users\... etc to D:/configs.
I then restarted IntelliJ.

Expected behavior:
changes are invisible within IJ, it hums merrily along and reads/writes config information to the new folder

Actual behavior:
The folder under c:\Users\... is recreated and I get the post-install wizard to import settings.

What am I missing?
7 comments

Hi Benjamin,

Could you upload your idea.properties here?

Denis

0

Hmm, that looks ok for me. Please provide your idea.log as well (main menu | help | show log).

Denis

0

I went through the process again, uncommenting the lines in idea.propertis, deleting the config directory under c:\Users\... and restarting.
Here is the log file produced:

It appears that it can't find any of the files under $APP_CONFIG$ or other directories, which I assume are supposed to be those specified in the properties file.
The startup folder D:\IntelliJ IDEA 12.1\bin is defnitely where my modified properties file lies. :-/



Attachment(s):
idea.log.zip
0

Thats weird. Will check that under windows environment later

Denis

0

I can tell you that this works fine on Windows. I did it for years. I even downloaded your idea.properties file, replaced mine with it, and started up IDEA 12.1.3. It created the D:\config\.IntelliJIdea12 directory. This was on Windows 7 x64.

You may want to make sure you do not have the IDEA_PROPERTIES environment variable set. If set, IDEA will use the properties file defined in it and not the one in the bin directory. If it is not set, try setting it to the fully qualified path of your custom properties file and see if it then creates and uses the correct config directory.

In the event you cannot find a solution, another option would be to use a symbolic link or junction. Replace the .IntelliJIdea12 directory in your C:\Users\... directory with a symlink or junction pointing to D:\configs\.IntelliJIdea12. I've used junctions to relocate my IDEA config directory (and other default configuration directories) to a separate hard drive. A nice advantage of them is you do not have to re-edit the idea.properties file each time you install a new version. I've found Link Shell Extension to be the best tool for exposing Windows/NFTS built in linking abilities into Windows Explorer.

0

Thanks Mark.  I don't know what settings where were causing this, but I checked the environment variables.  I did not have IDEA_PROPERTIES set, but when I proceeded to set it and try again, it worked.  No more recreating the directory on C.  Looks like things are now as desired.

0

Please sign in to leave a comment.