Creating new project from poms

When I import a project from multiple poms, the newly created project doesn't compile, because the project's language level is set to 1.3 and I use e.g. annotations.
In a parent pom all other poms use, I included the following:
org.apache.maven.plugins maven-compiler-plugin 1.6 1.6 ]]>

Selene seems not to use this setting.

3 comments
Comment actions Permalink

Hello Tobias,

We fixed such a problem a week ago. What build do you use?

Thank you.

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

When I import a project from multiple poms, the newly created project
doesn't compile, because the project's language level is set to 1.3
and I use e.g. annotations.
In a parent pom all other poms use, I included the following:
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-compiler-plugin</artifactId>
<configuration>
<source>1.6</source>
<target>1.6</target>
</configuration>
</plugin>
Selene seems not to use this setting.



0
Comment actions Permalink

I did run into this problem using build 7118.
I just started taking a look at Selena a couple of days ago.

0
Comment actions Permalink

Hello Tobias,

Fixed. Thank you.

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

I did run into this problem using build 7118.
I just started taking a look at Selena a couple of days ago.



0

Please sign in to leave a comment.