Gnome overriding shortcuts

Answered

Hello,

I'm using IntelliJ in Gnome in Ubuntu. When using Alt+F7 as or Alt+F8 shortcut, Gnome eats up these shortcuts (for move/resize window) instead of IntelliJ's "find all usages" or "evaluate expression".

Is disabling them in Gnome is the only solution? I guess this isn't really an IntelliJ specific question (and more a Gnome problem), but do you know how it comes that Gnome has shortcuts that override those of IntelliJ, even if IntelliJ has focus, and if there are maybe ways to change this behaviour without disabling all Gnome shortcuts?

I guess this problem appears for me only with IntelliJ because this program has so much shortcuts that it clashes with Gnome's.

Do other desktop managers or operating systems also have such shortcuts that override those of IntelliJ, or is Gnome the only one?

Thanks!

8 comments
Comment actions Permalink

You can change or disable these shortcuts in Preferences > Keyboard Shortcuts dialog.

Hello,

I'm using IntelliJ in Gnome in Ubuntu. When using AltF7 as shortcut, then instead of "find all usages", the mouse goes to the top of the IntelliJ window and it wants to move the intellij window. AltF8 (for evaluate expression) also does something similar.

I guess this are probably settings of Gnome, so I guess disabling them in Gnome is the only solution? I guess this isn't really an IntelliJ specific question, but do you know how it comes that Gnome has shortcuts that override those of IntelliJ, even if IntelliJ has focus, and if there are maybe ways to change this behaviour without disabling all Gnome shortcuts?

Thanks!

---
Original message URL: http://www.jetbrains.net/devnet/message/5254788#5254788



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

those are system shortcuts and cannot be overriden by an application (for example Alt+F1 being one of them).

In this case, Intellij provides you keybindings for linux (gnome and KDE), you can set those:

settings > keymap > keymappings > default for GNOME

hth

0
Comment actions Permalink

btw, there is a "Key promoter" plugin, which can help you remember new key mappings

0
Comment actions Permalink

I was using this plugin, and it's exactly what brought me to this question, it was suggesting alt+f7 if I chose "find usages"


Thanks for the replies!

0
Comment actions Permalink

I got used to XWin keymap so after switching to Gnome alt+f7 is not available for me anymore... But I found this article http://aprilmayjune.org/2012/04/17/change-keyboard-shortcuts-in-gnome-shell-gnome-3/ .
Now alt-f7 work again for me. Hope this will be helpful.

0
Comment actions Permalink

Thanks for the tip!

I used this trick to enable Alt-F7 to work as an IntelliJ keystroke when running IntelliJ 12 under Ubuntu.  However, it doesn't appear to work to convince Ubuntu to forget about Alt-F1.  Alt-F1 is still trapped somewhere else to do something with Ubuntu "dash".  This can be worked around by adding a different shortcut keystroke in IntelliJ, but my fingers are stubborn.  They keep remembering Alt-F1.  Has anyone figured out how to allow IntelliJ to use Alt-F1 under Ubuntu?

0
Comment actions Permalink

mutter-message disable-keybindings will temporarily disable all gnome 3 shortcuts.

0
Comment actions Permalink

For anyone looking for the answer in 2019 - I already checked the "System Settings" and "Tweaks" and found nothing.

Most of the shortcuts are now for some reason accessible only using "dconf editor" in section "org/gnome/desktop/*/keybindings". By the asterisk I mean that every subsection of "org/gnome/desktop" has "keybindings" subsection. You might have to go through all of them to find your shortcut.

I don't know why it was designed this way, but at least the shortcuts are not hardcoded anymore, I guess.

1

Please sign in to leave a comment.