Slow editor scrolling on Java6, Selena

I had to start to use JRE 1.6.02 with IntelliJ IDEA because of often random JVM crashes on JRE1.5.11. It solved my problem with instability, but I started to feel a big slowness of editor scrolling (via mouse scroll button). I tried to switch off property Smooth Scrolling (IDE Settings->Editor->Scrolling), but it had NO effect.
I know that Java6 is not still officially supported, but can someone else check this please?

-Cavity
Selena #7087

8 comments
Comment actions Permalink

On 2007-07-28 19:33:34 +0400, CaVity <no_reply@jetbrains.com> said:

I had to start to use JRE 1.6.02 with IntelliJ IDEA because of often
random JVM crashes on JRE1.5.11. It solved my problem with instability,
but I started to feel a big slowness of editor scrolling (via mouse
scroll button). I tried to switch off property Smooth Scrolling (IDE
Settings->Editor->Scrolling), but it had NO effect.
I know that Java6 is not still officially supported, but can someone
else check this please?

-Cavity
Selena #7087


Please take a CPU snapshot and we'll see what's wrong there.

0
Comment actions Permalink

CaVity wrote:

I had to start to use JRE 1.6.02 with IntelliJ IDEA because of often random JVM crashes on JRE1.5.11. It solved my problem with instability, but I started to feel a big slowness of editor scrolling (via mouse scroll button). I tried to switch off property Smooth Scrolling (IDE Settings->Editor->Scrolling), but it had NO effect.


Sounds like http://www.jetbrains.net/jira/browse/IDEA-10739

Sascha

0
Comment actions Permalink

It takes full CPU load. My CPU is a bit old 1GHz and that is why I can feel the difference. People with the faster CPU probably don't notice that at all. I'm not sure if the setting of the property works.

0
Comment actions Permalink

Yeah, that's it! I am not alone! ;-). I'll try to set the "sun.java2d.noddraw=true"

0
Comment actions Permalink

Commenting of the line helped a lot. It's much faster. I didn't notice any glitches or redraw problems (on very old TNT2 Ultra). Enabling/disabling of the smooth scrolling property seems to have still no effect.

0
Comment actions Permalink

Opening any XML-file in editor could help you. At least it helps me. Strange behavior.

0
Comment actions Permalink

I can also add that it works at least on two machines.

0
Comment actions Permalink

And I should also add (maybe for IDEA developers), that commenting "sun.java2d.noddraw=true" didn't help, and scrolling becomes even slower and CPU load is 100% now.

0

Please sign in to leave a comment.