Regression: IDEA 12.0 -> 12.1

I upgraded to the 12.1 version of IDEA from 12.0 and my entire project broke... It will no longer resolve many references within the project - in the same module or otherwise. It seems to be generally related to certain class annotations that it seems to no longer be processing, but I'm not completely sure. Rebuilding doesn't help - in fact, it claims to rebuild fine despite all the errors in shown in the editor. I reinstalled IDEA 12.0 and things work again.

3 comments

Hi Scott,

Please try to call main menu | file | invalidate caches.

Provide your idea.log (main menu | help | show log) if the above doesn't help.

Denis

0

Hi Denis,

Ok. So I shut down 12.0 and started 12.1 again in order to try what you suggested... but now everything in the project looks ok!  Apparently going back to 12.0 fixed the issues that 12.1 was having?  This is odd because I had tried restarting the IDE, deleting the project & iml files and recreating the project (from the pom) in 12.1, restarting the IDE again, etc... but nothing had worked.  So... I don't why this finally fixed it, but it's working now.

Thanks,
Scott

0

Ok, thanks for the update.

Please try the actions I suggested above if that occurs again.

Denis

0

Please sign in to leave a comment.