13 comments
Comment actions Permalink

works fine for me.

what issues are you having?

how have you tried to get it working so far?

Regards

Peter


Tom wrote:

Anybody got it working?



--
Peter Vandoros
Software Engineer
Etech Group Pty Ltd
Level 3/21 Victoria St
Melbourne VIC 3000
Australia

Ph: +61 3 9639 9677
Fax: +61 3 9639 9577
-


IMPORTANT: This e-mail message and any attachments are confidential and
may be privileged. If received in error, please reply to this message
and destroy all copies and any attachments. You should check this
message and any attachments for viruses or defects. Our liability is
limited to resupplying any affected message or attachments. For more
information about Etech Group, please visit us at
http://www.etechgroup.com.au.

0
Comment actions Permalink

Well, in my project 'Subversion' is selected. When I now open the Changes
view, tab Committed and select the Refresh, I just get following error message:
Error refreshing changes: svn: PROPFIND request failed on '/my/path'svn:
Received fatal alert: handshake_failure

But IDEA did not ask me for any credentials.

0
Comment actions Permalink

Hello Tom,

Well, in my project 'Subversion' is selected. When I now open the
Changes view, tab Committed and select the Refresh, I just get
following error message: Error refreshing changes: svn: PROPFIND
request failed on '/my/path'svn: Received fatal alert:
handshake_failure

But IDEA did not ask me for any credentials.


Which build did this happen with?

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Have you tried clearing the authentication cache and then restart IDEA?
I find this helps.

Also, make sure that your private key is in the OpenSSH format.

Regards
--
Peter Vandoros
Software Engineer
Etech Group Pty Ltd
Level 3/21 Victoria St
Melbourne VIC 3000
Australia

Ph: +61 3 9639 9677
Fax: +61 3 9639 9577
-


IMPORTANT: This e-mail message and any attachments are confidential and
may be privileged. If received in error, please reply to this message
and destroy all copies and any attachments. You should check this
message and any attachments for viruses or defects. Our liability is
limited to resupplying any affected message or attachments. For more
information about Etech Group, please visit us at
http://www.etechgroup.com.au.

0
Comment actions Permalink

The core problem is, that IDEA does not ask me for my credentials, so I did
not entered the private key file yet.

Tom

0
Comment actions Permalink

Did you "clear authentication cache"?

Tom wrote:

The core problem is, that IDEA does not ask me for my credentials, so I
did not entered the private key file yet.

Tom



--
Peter Vandoros
Software Engineer
Etech Group Pty Ltd
Level 3/21 Victoria St
Melbourne VIC 3000
Australia

Ph: +61 3 9639 9677
Fax: +61 3 9639 9577
-


IMPORTANT: This e-mail message and any attachments are confidential and
may be privileged. If received in error, please reply to this message
and destroy all copies and any attachments. You should check this
message and any attachments for viruses or defects. Our liability is
limited to resupplying any affected message or attachments. For more
information about Etech Group, please visit us at
http://www.etechgroup.com.au.

0
Comment actions Permalink

Although I don't know about an "authentication cache", I've wiped my
~\.IntelliJIdea70\system directory and restarted IDEA. It still did not ask
me for my Subversion credentials, so the refresh failed again.

Tom

0
Comment actions Permalink

Same problems on 7065.

0
Comment actions Permalink

I don't know what OS you're on, but on Windows the authentication data is stored in a different directory:

C:\Documents and Settings\User\Application Data\Subversion\auth

I'm assuming this is because it uses SVNKit in the background. I've also no idea if this happens on other operating systems.

0
Comment actions Permalink

The way i do it is:

Project Setting -> Version Control -> Select Subversion from list ->
Configure VCS -> Clear Authentication Cache

IDEA has always then asked me to provide the authentication credentials
again.

If it doesn't work as described, then restart IDEA after you clear the
authentication cache and before you try to specify your authentication
details.

Regards
--
Peter Vandoros
Software Engineer
Etech Group Pty Ltd
Level 3/21 Victoria St
Melbourne VIC 3000
Australia

Ph: +61 3 9639 9677
Fax: +61 3 9639 9577
-


IMPORTANT: This e-mail message and any attachments are confidential and
may be privileged. If received in error, please reply to this message
and destroy all copies and any attachments. You should check this
message and any attachments for viruses or defects. Our liability is
limited to resupplying any affected message or attachments. For more
information about Etech Group, please visit us at
http://www.etechgroup.com.au.

0
Comment actions Permalink

C:\Documents and Settings\User\Application
Data\Subversion\auth

I'm assuming this is because it uses SVNKit in the
background. I've also no idea if this happens on
other operating systems.


SVNKit (and thus IDEA) is just following Subversion standars. This is the directory where the standard subversion client store it's certificate, and by using it, IDEA will share configurations with the command line client.

0
Comment actions Permalink

Project Setting -> Version Control -> Select Subversion from list ->
Configure VCS -> Clear Authentication Cache


Thanks for the hint, it wasn't obvious to me. Unfortunately, clicking the
'Clear Authentication Cache' button and then clicking the Refresh button in
the Committed view of the Changes panel shows the error message again. IDEA
does NOT ask me for my credentials.

0

Please sign in to leave a comment.