Code folding happens even when disabled

In File | Settings | Editor |Code Folding      NONE of the checkboxes are checked.  That has been the case since installation 4 months ago

However:  In the following code it all gets folded every time i go to the file.  So i have to manually unfold them (and occasional other code fragments as well).

    }
    try {
      conn = DB.getConnection(DBFromMR.readProps(conf, conf.get(CurlToS3Job.DB_CONFIG_FILE)));
    } catch (Exception e) {
      throw new RuntimeException("Unable to connect to " + MyJobDB_CONFIG_FILE, e);
    }

Gets folded into one line

So .. how do I permanently disable code folding once and for all?

(note: i had some earlier conversation about this, but this problem occurs in both scala and in java)

I am on 12.0.4 utimate.

5 comments

This is happening on code that makes no sense to fold : e.g. the following


  private static String getProperty(String name, String defaultVal) {
    String prop = mapProps.getProperty(name, defaultVal);
    if (prop == null && defaultVal == null) {
      trace("WARNING: property " + name + " not found");
    }
    return prop;
  }

  private static String getProperty(String name) {
    return getProperty(name, null);
  }

I mean .. why would those two methods get folded automatically?  (Let alone that I have disabled all code in the project settings).

0

Hi Stephen,

'File | Settings | Editor | Code Folding' allows to configure default foldings, i.e. the rules to apply during opening files for the first time.

All explicit folding state changes are saved on a per-file basis and are applied on its subsequent re-opening.

Am I right understanding that even when you manually unfold all method foldings and close the file at the ide, they re-appear when you reopen it?

Could you check if the problem persists at java code if you remove scala plugin?

Denis

0

Hi Denis,
I already tried that thing of disabling the scala plugin six months ago and it did not help.  I do actively use scala so removing it is intrusive to my work.

Right now the code folding is a real problem.  It is hiding code all over the place  .  E.g. it is hiding heredocs in my ruby code . That's key stuff for my work.

I will disable the scala plugin again in the coming weekend.

0

Just to be clear - I don't propose to disable the scala plugin forever, the idea is just to find out the problem's reason.

Denis

0

I have the same problem. I just upgraded to version 2016.3 and now all code (i.e. for / while / try / etc.) gets folded every time. This is the most obnoxious, impractical and dumb feature I've ever seen in a code editor.

Is it is possible at all to disable this dumb feature? The previous version I was on only folded regions and that worked pretty well.

If this is not possible how do I revert to the previous version?

 

Thx...

jjb 

0

Please sign in to leave a comment.