Android Emulator Start x86?

When I start the Android emulator from IntelliJ, I get something like this:

"C:\Program Files (x86)\Android\android-sdk\tools\emulator.exe" -avd 4_1_2 -netspeed full -netdelay none -no-boot-anim

I want to be able to start the x86 version through the IDE, but can't seem to find any way to do so.  I have been doing starting via command line.  Is there something I am missing?

"C:\Program Files (x86)\Android\android-sdk\tools\emulator-x86.exe" -avd 4_1_2 -netspeed full -netdelay none -no-boot-anim

7 comments

I'm running the x86 version. I've set this in AVD Manager:
Tools > Android > AVD Manager
Than select your projeject's preferred Android Virtual Device and click Edit...
In the edit dialog under CPU/ABI, select Intel Atom (x86) and you'll be fine.

Bonus tip for working with hi-res virtual devices :)
In AVD Manager, select projects preferred AVD and click Start... to open Launch Options
Check Scale display to real size and take a mental note of the calculated Scale, let's call it <scale_number>
Click cancel and close the AVD Manager
Than, in Run/Debug Configurations dialog (Run > Edit Configurations...), assuming your project is already selected, click the Emulator tab, check the Additional command line options and enter:
-scale <scale_number>

0

I am using IntelliJ 12.0.4, and no matter what may AVD config is, it runs emulator.exe instead of emulator-x86.exe.  It is obviously setup correctly for x86 since I can run it command line with the same AVD config.  I guess if it works for someone else, I will file a bug.

0

As I know, emulator.exe is universal executable and you may launch x86 instance as described above. Why do you think you need to use emulator-x86.exe (there are also emulator-arm.exe and emulator-mips.exe)?

0

On Windows, the emulator-x86.exe needs to run in order to trigger HAXM virutal acceleration (installed separately).  With HAXM, the emulator is nearly as fast as a device, and it makes for a much better development experience.

0

Ok, please create an issue in our tracker and we'll think about it

0

Please sign in to leave a comment.