Hot Redeploy is not working: "schema change not implemented"

I have changed one file in my project and tried to make Hot Redeploy. Idea failed with the message

Hot Swap failed
         Server Debug: schema change not implemented;
         Server Debug: Operation not supported by VM


I am surprised because I was changing just 2 method's internals and not the method's signatures.

A possible reason is that the class I changed actually belongs to Maven artifact which is differrent from the artifact used to build the deployed version of my application I want to debug. I cannot change the class from the artifact which is deployed becaused it comes from maven as a dependency and I cannot change the code in a dependency, its just downloaded by Maven and thats all.

I tried to say to Idea to look for classes inside the package where my new file is placed, but I get the same error.

So I am not sure can I fix it somehow, whether the problem is in different artefacts, or may be in something else?

Can I hot-swap a class which has the same name and package as target class, but located in the artifact with another name?

What can I do  to test my new code without redeploying?

3 comments

Hi Dmitry,

What kind of application do you use? j2se, j2ee, web, something else?

Denis

0

Denis,
I have a Web-Service deployed on JBoss server.

Today I have encountered it for the second time: I tried to redeploy class where I have added private method and placed two calls of that private method in other methods. No public signatures were changed. And I still have the same error message.

0

That is standard jvm hotswap limitation - it allows only method body change, not method addition/removal.

Denis

0

Please sign in to leave a comment.