Unable to create local connection on Debian Sid

Hello everyone,
I've been a longtime IDEA user but just recently switched to Debian. This is what I'm greeted with upon startup:

IDEA was unable to create a local connection in order to check whether other instance of IDEA is currently running on the same machine. Running multiple instances of IDEA on the same machine may cause unpredictable results because of sharing system folders. Please troubleshoot your TCP/IP configuration and/or local firewall settings. and attach the ~/.IdeaC12/system/log/idea.log file


I thought that was a bit strange, but decided I could live with it so long as I didn't try to open another IDEA process.
Upon trying to build and run my first project, however, I was given this error:

Failed to bind to: /127.0.0.1:xxxxx


where "xxxxx" is a random 5-digit port number (for example, 45378).
As a non-privledged port, most of the information I found online about allowing normal users to use privledged ports didn't apply to my problem. Also, running IDEA as root produced the same error. I've gone so far as to remove iptables, thinking that was the issue, but to no avail.

Here is some information about my system:

colin@digislum:~$ uname -r
3.2.0-4-amd64

colin@digislum:~$ java -version
java version "1.7.0_17"
Java(TM) SE Runtime Environment (build 1.7.0_17-b02)
Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)


colin@digislum:~/apps/idea-IC-123.169$ cat build.txt
IC-123.169


Anyone have any idea what's going on here? I'm ready to learn Netbeans or Eclipse at this point...

3 comments
Comment actions Permalink

Hi Colin,

Haven't seen such reports before. Try to disable external make and check if that helps - ide settings | compiler | use external build

Denis

0
Comment actions Permalink

A friend got the same error on 12.0.4 build, Windows 8, Java 1.7.0_13 as well. The installation worked the first time installed. Then started getting this error everytime it starts since the 2nd day. The log shows the embedded netty has something to do with it. Will post more info once I got in touch with the friend again.

----------------
Follow up:

The cause of our case is found and solved. The friend installed an office like software which was bundled with a so called guardian software doing some firewall work. Once this software was uninstalled, 12.0.4 went back to normal.

However, I'm still surprised that 12 requires an embedded netty in order to invoke the compiler.

0
Comment actions Permalink

In hindsight this should have been the very first thing to check, but for some reason or another Debian wasn't configured to start a loopback interface out of the box. Whoops! Everything works fine now, thanks for the interest/suggestions.

0

Please sign in to leave a comment.