EAP objectives changed?

It used to be that one could do work with the EAP releases. Certain things would be broken or "in progress" but the software would be "usable" for early adopters.

The latest 3-4 releases of Selena seem to be something very different. They seem to either be entirely untested or known to be unusable.

Don't misunderstand me. I realize that I shouldn't have any expectations at all for unreleased software, and that I'm entirely on my own when using it. However it would help me to know if I indeed should no longer expect to be able to use the EAP releases. In that case I'll stay away from the EAP program.

15 comments

I've been using the last 3-4 releases for developing a large Java desktop app (no web or server stuff) without major problems - a few errors popping up and the occasional overlong pause while editing, but nothing worse than we had with the early Selena EAP builds. No showstoppers here...

0

There are showstoppers. Right now mostly relating to facets. Not being able to creat a facet effectively means not being able to create projects.

Since you don't have this problem perhaps you could post the solution to thread 268113. That would be more helpful than merely asserting that the problems don't exist.

0

I'm using all latest releases for my daily work and it works most of the time just fine (except the issue with comments in *.ipr files generated by "mvn idea:idea" and ClearCase support which seemed to never work but latest build claims it should now .. will see in a couple of hours).

0

There are showstoppers. Right now mostly relating to
facets. Not being able to creat a facet effectively
means not being able to create projects.


These problems may be show stoppers for some people, but not for everyone. It's good that they're releasing early builds so at least some people can test the areas they're working on, even if some will find it completely unusable duo to problems in areas they still aren't focusing on.

IDEA has grown a lot -- Selena is much more complex than, let's say, IDEA 2.0 (I forgot the code name) ever was, and I guess this kind of problems during the development cycle are expected (I still expect a polished as ever product on release, however).

0

You use EAP at your own peril and must be prepared to roll back to the previous version. It is not guaranteed to work flawlessly and if you use it in production environment, you must accept the associated risks. That's an integral part of the EAP "contract". Otherwise, you should use the officially released version.

As I am not using any enterprisey stuff (and thanks for allowing me to disable it in the plugin manager), the latest EAPs work fine for me, especially 7000+ builds.

0

Last few Selena EAP builds are throws tons of Exceptions; let's hope they will fixed all before Beta program.

0

I'm using enterprise stuff: JSF, ejb3. I haven't found showstoppers. Certainly, there have been some bugs in the last couple builds which were more annoying than usual, but I plodded through.

0

only one critical error here (web facet/tomcat config)
i used an older version to create the project, then swichted to the latest eap again

0

I must admit that I felt your frustration around the mid 6800 builds, but since then I've been able to use it pretty reliably. The last few builds have been great for me.

0

This is understood, as I made quite clear in my post.

Again, I don't have any issues at all with the EAP program, and I fully understand the implications of using pre-release software. But thank you, nonetheless, for the bombastic sermon. ( I suppose it was inevitable ).

My point was simply that whereas EAP builds have tended to me usable since I've started downloading them (around version 5), the last Selena builds were not. This is just fine.
However, if this will be the norm moving forward, It will be good to know. I have the choice of
sticking with the release bits and ignoring EAP.

BTW, I still love Idea and remain a loyal customer and user..:-)

0

IDEA choking on comments issue has been already fixed, I think in b7041.

0

I have stuck with the Milestone 1b build and it is considerably slower in our project for than it was with Intellij 4.5.4. I really wish sometimes they just took 4.5.4 fixed more bugs, slapped some new features on it changed the UI to look like the current UI and left it at that casue that was a FAST ide!

0

I've been using the last 3-4 releases for developing
a large Java desktop app (no web or server stuff)
without major problems - a few errors popping up and
the occasional overlong pause while editing, but
nothing worse than we had with the early Selena EAP
builds. No showstoppers here...


Same for me.

Francesco

0

idea's speed didn't change for me... i started at idea 3.0 using a 1ghz p3 with 512mb ram, now i'm always at the latest eap - and a 2.7 ghz dual opteron and 2gb ram^^

yes, it got slower. 2 out of 3 people at my company are still using idea 5.1.2 instead of the newest releases/milestones/eaps, and i see a big difference if you're one of those "i use all of my fingers when coding and reject most hotkeys"-type programmers. i pretty much use only hotkeys (ok, might be a exaggerating a bit here), and the new features make up for it (bless "fix all")

0

From my personal perception, there has been a dramatic increase in performance in 7000+ builds. Again, I must admit I am not using any enterprisey stuff, but the latest EAP builds handle our project (10,000+ classes) effortlessly. The start-up time is, probably, 100 times shorter now. There are far less lock-ups now as well, because more operations are shifted into background (and most of them can be cancelled while in progress). I am absolutely not going to roll back to version 5.x.

0

Please sign in to leave a comment.