Idea loads wrong source for dubgging

Hi,

I have two wars in my project each using same dependency but with differenet versions. When debugging with run:jetty source is being loaded from wrong dependency, i.e. one from other war. Is there any way to tell debugger to take sources from correct location?

Best regards, Eugene.

9 comments

Hello,

Can you provide a sample project which illustrates the problem?

Denis

0

Sorry, no. I just have not time. I believe I described the problem precisely enough.

0

What do you mean by "debugging with run:jetty"? Which kind of a run configuration do you use to start Jetty?

--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Thank you! That's exactly my case!

0

IDEA indeed isn't smart enough to determine which war is deployed when you start Jetty via Maven. However if you start Jetty using a Jetty run
configuration IDEA will know which war artifact is deployed so the problem should go away.

--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Thank you, it could be a workaround. Although there is quite a major drawback - by using Idea's Jetty run configuration I introduce one more environment which I have to maintain, i.e. keep all config in sycn with pom. That's quite awkward. You'd better fix the maven config :)

0

It doesn't work for a Tomcat run configuration ... (see issues in the other post below)

Regards,
Wallaby

0

Please sign in to leave a comment.