7.0 EAP and academic License

I have an academic license version of the Intellij. When I try entering the license information for the Intellij 7.0m1, I get an error message telling me to upgrade. Does the Academic license prevents users from trying the latest Intellj?

Kent

Please sign in to leave a comment.