intellij idea 12 & adobe scout ( monocle ) on windows

Here is a little step by step on how to integrate these fantastic tools. Worked for me :)

1. download and install python :
2. download and install python setup tools :
3. download and put in python scripts folder :
4. add both python.exe and easy_install.exe to path environment : ;C:\Python27\;C:\Python27\Scripts\
5. go to pylzma site : (here you'll find the link you need to the next step)
6. install pylzma for lzma compression in swf : run : easy_install (or the file related to your python version)
7. create you external tool in intellij idea
 Program : C:\Python27\python.exe
 Parameters : $Classpath$\<filename>.swf
 Working Dir : C:\Python27\Scripts\telemetry-utils-master (this is where i put the script)
8. use in your project :
 a ) edit configurations -> options -> launch with : <path for flash player debugger 11.5>
 b ) edit configurations -> before launch -> <add run to your external tool>
9. run scout and run configuration in intellij. tested and worked !

Good luck !

Comment actions Permalink


Thank you for these intructions.

They worked great, even with installing 64 bit python, for local applications.

I am using this with a mobile project, and using themmobile emulator it will connect to Scout and debug.

thank you,

-Steven Stark

Comment actions Permalink


I am having one issue still with this setup, and that's with debugging on my mobile device using this setup. The app would be an .apk, and the android device does have scout installed into it. I will do some light troubleshooting on my end and get back to you with results, if positive.

Here's the error:

C:\Python27\python.exe D:\Projects\slotspot-mobile\out\production\slotspot-mobile\<filename>.swf
Traceback (most recent call last):
  File "", line 137, in <module>
    swfFH = open(infile, 'rb')
IOError: [Errno 22] invalid mode ('rb') or filename: 'D:\\Projects\\slotspot-mobile\\out\\production\\slotspot-mobile\\<filename>.swf'

Process finished with exit code 1

Do you have any thoughts?


Comment actions Permalink

Ignore my last comment, it all works! I just failed to properly setup the scout app on my device to connect to the pc scout app.


NOTE: The checkbox to setup the config in the app is light grey and blends into the dark grey background. I didn't see it!

Also, it's worth noting this ant based link:

Comment actions Permalink

Hey man, thanks!

How does the pylzma compression factor in here? I don't see it being called or used in this process.  Could you clarify and advise?

Thanks, kind regards,

Comment actions Permalink

pylzma is required for adobe scout to read swf using lzma compression (version 11.something, not sure)


Please sign in to leave a comment.