what Struts versions does the facet support?

On 7.0M1a, the project I'm looking at now has Struts 1.1. When I try to add a Struts facet to the web module, the Select Struts version is grayed out on 1.2.x. (I tried creating the facet anyway, but it complains about missing jars and then throws an exception when I try to add them.) The Struts Assistant shows nothing, and Help shows a Struts Assistant in the Project Settings but I don't see any. (I guess the Help just hasn't been updated yet.)

3 comments
Comment actions Permalink

Thanks for feedback. I've created two issues:
http://www.jetbrains.net/jira/browse/STRUTS-187 (about Struts 1.x versions
support)
http://www.jetbrains.net/jira/browse/IDEA-12538 (about outdated help topic)
Please report the exceptions you see.
But your application should be recognized anyway. Does navigation work for
your configured struts files in the web.xml?


0
Comment actions Permalink

Thanks! The struts-config.xml in my web.xml was red and IDEA said it couldn't find it. The problem seems to be that I was deploying my web module in place. When I unchecked "Exclude from module content" on Java EE Build Settings then IDEA found it and my Struts Assistant filled in! This looks much better!

I still see the same problem when trying to create a Struts facet, though. What features would the facet add?

0
Comment actions Permalink

Mmm... Facet creating is a bit screwed up at the moment :) Intentionally it
should contain all Struts-relative configurations/options.


0

Please sign in to leave a comment.