6 comments

File->Project Structure->[choose Module]->Tab "Sources" use "Excluded" button on top of tree to mark seleted directory as excluded

0

Thanks for the quick answer Yann.
But there is any other way? I need some folders to be on classpath when I execute the tests.

0

Could you describe why the indexing does not work for you? Is it a performance problem in your project?

0

Hi,
There is no problem due to xml indexing. Just performance.

I have around 15 maven projects open in my Indellij project, 3 or 4 have big xml datasets for testing.
Sometimes, when I update the IDE, or a plugin, it end up reindexing the whole thing.
And as I don't edit those files, I was trying to disable it. I was hoping that it would reduce the memory consumption too(just a guess).

0

Hi Rodrigo,

You can try to reduce 'idea.max.intellisense.filesize' (2.5 Mb by default) property value (configured at $IDEA_HOME/bin/idea.properties) and check if that helps.

Denis

0

I changed the folder structure from the projects, and exclude the folder with XML as you said. That should fix.
Seems that I was looking for a IDE solution, when what I had was a structure problem.
Thanks again.

0

Please sign in to leave a comment.