Keymap issue in the GUI Designer (OSX)

Hi everyone,

I have a keyboard shortcut issue within the GUI Designer on Mac OS X.

When I type the keyboard shortcut for the "Create Component" action, nothing happen. However, when I run this command using the context menu, everything is fine.

I have  tried to change the default shortcut, but I didn't even find the action in the keymap setting panel. A search with the string "Create component" didn't find anything interessting.  I have surely missed it, but after half an hour I gave up (computer 1, me 0 :))

My environment :

  • Mac OS X 10.7.5 / Mac mini I7 serveur / full Mac keyboard
  • IntelliJ 12
  • Keymap used for test : Mac OS X 10.5+ (Command + N) / Mac OS X (Ctrl + N)


Any suggestions?

Thanks,

Boris

3 comments
Comment actions Permalink

The "Create component" action is not separately available in the keymap because it reuses the shortcut of the standard "Generate" action. The action works fine for me; please make sure that you have a component selected in the UI Designer when you invoke the action.

0
Comment actions Permalink

Hi Dmitri,

Thank you for the answer, but unfortunately it still doesn't work on my side.

Using the default "Mac OS X 10.5+" keymaps, when I press the generate shortcuts (Command+N) in a java code, the generate menu appears as expected. So it seems that the Command+N shortcuts is not trapped by another app. But when I invoke this shortcut in the UI designer, nothing happen.

>  make sure that you have a component selected
I have tried several time, without any success, by selecting different kind of component : Form, JPanel, JLable, JComboBox.

I have also tried with a newly created project (using the "Java Hello World" Samples, with/without a custom keyboard shortcut.

I'm surely missing something obvious…

Do you have any other ideas ?

Thank you for your help,

Boris

0
Comment actions Permalink

Dear all,

Just for information.

The new release '12.0.2' solved my issue. Everything works fine :)

Best regards

Boris

0

Please sign in to leave a comment.