Uncaught ReferenceError: $ is not defined when debugging jQuery

I created a web module app in Intelli J 12 (pure html, css3 and Javascript) and downloaded jQuery and jQuery UI.
jQuery is not working and when I debug I get :Uncaught ReferenceError: $ is not defined <- which says that jQuery is not loaded.
So what am I missing? why is jQuery not loading?
Both jQuery libraries are in the global libraries configuration for the project.
After linking the script to the html my first line in the script is:
$(document.ready(function(){"code here"});

Regards,
Felipe

4 comments

Could you please clarify if your app works without debugger ?

0

If you are with that:

...(pure html, css3 and Javascript)...


so you can start solving jquery issue by using 'plain static js/css code' like (or other way):


    <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js"></script>

    <link type="text/css" rel="stylesheet" href="http://ajax.googleapis.com/ajax/libs/jqueryui/1.9.2/themes/base/jquery-ui.css" media="all"/>
    <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.9.2/jquery-ui.min.js"></script>


and make you HTML 'happy' workin with that.

And then later try to solve problem with jquery by adding 'jquery' library into IJ
0

Hi, This solved the issue. But first I had to delete the jquery and jquery ui libs from the computer, then the app worked and afterwards I added the libs again and it's working, although I don't think I'm using the libs that Intelli J downloaded and installed.

I didn't have before a link to the jquery that Intelli J installed because I assumed that they where automatically included in the project path. I'm a newbie to jquery and javascript son it didn't occur to me to include the paths to the libraries in the html.

Regards,
Felipe

0

Please sign in to leave a comment.