Intellij Idea 12 fails to connect to JBoss 7.1.1 remotely

Hi, guys!

I've recently switched to IDEA from Eclipse and because of that I have every day problems. Some I can resolve with myself, some not. This is problem, that I can't resolve about 2 hours.

I used to use in Eclipse remote debugging of JBoss server. I don't like to run it from IDE. I run server from console and then when I need it I remotely connect to it. So I know about required configuration of JBoss like additional JAVA_OPTS "-Xdebug -Xrunjdwp:transport=dt_socket,address=8787,suspend=n,server=y". Moreover after JBoss was started I can connect to it with Exclipse but not with IDEA. I found several solutions but they are very old and didn't work on new IDEA and JBoss.

Only one works - starting JBoss under sudo, but it is unacceptable.((

My configuration - OSX 1.8.2, JBoss AS7, IDEA 12 and I've attached my debug config dialog.

And yes despite of all my switching problem I think I'll love IDEA.))

Thanks in advance.



Attachment(s):
50e08cd4e4b05c01ee9a09cf.png
1 comment
Comment actions Permalink

I've found solution. May be this problem appeared because I just switched from Eclipse. So I think someone it can be helpful.

 

For correct debugging JBoss remotely we need to specify 3 ports:

1) http port ('Port' field of the 'Remote Connection Settings' section) is used to ping JBoss server (periodical checking if the
server is alive) and to produce urls addressing resources on the server - FIRST TAB

 

2) native management port ('Management port' field of the 'JBoss Server Settings' section) is used to connect to the JBoss management 
interface, to check for the server startup to be finished and to deploy artifacts - FIRST TAB

 

3) remote socket port - by default on JBoss it 8787 - LAST TAB

 

After this all will work fine.

I was little bit confusing because if I run JBoss under sudo – all remote debug worked just fine.

0

Please sign in to leave a comment.