how to completely remove Intellij

Please see also this thread:  http://devnet.jetbrains.net/message/5472994

basically, my Intellij got into a state i can't even start it, I tried to uninstall and remove any leftovers, but doesn't help.

Can someone provide a complete list of things that needs to be removed to insure 100% removal of Intellij so i can restart?

Thanks,

4 comments
Comment actions Permalink

You do not mention what OS. But in most cases it is simply:

  1. Delete the installation directory
  2. Delete the "config" and "system" configuration directories. These contain IntelliJ IDEA's caches, configuration and plugins. See http://devnet.jetbrains.net/docs/DOC-181 for the OS specific locations of these two directories. On Windows and Linux platforms they are contained in a single directory in the user's home directory (profile directory). With Mac, they are split up.
    • You may want to try just deleting the system directory. That is often enough to fix a corrupt install. And then you would not lose your configuration settings. If it doesn't work, you can then delete both.


That should be all you need. On Windows, the only registry entries are for a file association. If you want to be completely thorough, you can delete those, but I doubt they would cause any issues. They are (to the best of my knowledge):

  • [HKEY_CLASSES_ROOT\.ipr]
  • [HKEY_CLASSES_ROOT\IntelliJIDEAProjectFile]
  • [HKEY_CLASSES_ROOT\IntelliJIDEAProjectFile\DefaultIcon]
  • [HKEY_CLASSES_ROOT\IntelliJIDEAProjectFile\shell\open\command]
0
Comment actions Permalink

On Sun, 02 Dec 2012 12:26:35 MSK, sean  w <no_reply@jetbrains.com>
wrote, quoted or indirectly quoted someone who said :

>
>basically, my Intellij got into a state i can't even start it, I tried to uninstall and remove any leftovers, but doesn't help

Look in the tips section of http://mindprod.com/jgloss/intellij.html
--
Roedy Green Canadian Mind Products http://mindprod.com
Students who hire or con others to do their homework are as foolish
as couch potatoes who hire others to go to the gym for them.

0
Comment actions Permalink

Hi Mark,

Thanks for the info.

The OS version is OSX 10.7.5.  I downloaded the community version from here: http://www.jetbrains.com/idea/download/

I have checked and there is nothing at the four locations mentioned in the link, however, I do notice that when start, it did a little bit something, it created a directory at ~/Library/Caches/IdeaIC11/
but that's about the app just hang.

in the linked issue I posted, I also have the hang screenshot, crash dump, and info obtained from activity monitor attached, please let me know if you have problem seeing them.

Thanks,

Sean

0
Comment actions Permalink

Hey guys, I realized the issue is really that I manually repointed to jdk6 on my machine, that caused the problem. pointing back to 7 worked.

Thanks,

Sean

0

Please sign in to leave a comment.