IntelliJ stopped completion, highlighting, etc

(I'm new to linux and java but have been on windows and .NET for >12 years, and c++ on Windows for >20 yrs).

I have 2  java projects under Maven. I needed to add another module to projectB so that I can call into it from ProjectA.
I added it and have no problems compiling from the bash shell, but now none of the syntax highlighting, completion, or anything like that works any more in IntelliJ.
I  could live with compiling on the command line, I can't debug and editing in this environment is about as useful as using notepad or gedit.
There are no completions to be found or syntax highlights to come through.  Evenif I add a line of gibberish to force an error in one of the previously working java files,
and tell intelliJ to build the entire project, it succeeds without showing any errors.

I tried deleting every single iml file in the project and reloading, but no joy.  I cleared the cache from the menu as well as deleted the system cache directory.

There is obviously some kind of issue with the project but I don't know where to look to resolve it.

Where do I start so I can figure out what might be causing this disconnect?

Thanks-
Steve

4 comments
Comment actions Permalink

I reinstalled IntelliJ and now everything works.

0
Comment actions Permalink

If that happens again, try going to File > Invalidate Caches and then restart IntelliJ IDEA. That will usually fix the issue you describe (which is typically caused by corrupted indexes or caches).

0
Comment actions Permalink

Thanks but I had already tried that and many of the other things that appeared on this as well as several other boards/blogs.

Reinstallation was the only thing that worked.  Something got horked and unfortunately I don't know what that was.

0
Comment actions Permalink

and have you looked into logs for some interesting thing?

0

Please sign in to leave a comment.