Where is the option that controls the classpath response file

A couple of days ago I tried to debug an application with a very long classpath.
IntelliJ told me that the classpath was too long and that it had to use a temporary file. I accepted.
When that option is turned on, IntelliJ starts java with a @vm_param option.

Today I tried to reset that option to the default and couldn't find it in the UI.
I have looked at the settings and project structure but couldn't see anything related.
I have also tried to find the option in the XML configuration files still with no success.
I eventually had to download the sources and debug IntelliJ to find the option.

<project>\.idea\workspace.xml contains a "dynamic.classpath" property that must be turned back to false to reset the option to the default.

1) Is there a UI to set that option?
2) If there isn't, I hope this post will help the next person who encounters that problem.

Using IntelliJ 11.1.4.

Thanks,
-Cedric

2 comments
Comment actions Permalink

By the way, the reason why I wanted to change it back is that I suspected (and just confirmed) that this was the cause for another problem.
When debugging a Grails application, if that option is turned on (when java is started with @vm_params) changes that you make to the Grails sources are not reloaded/hot-swapped.

0
Comment actions Permalink

Here is the popup that enabled that option.

Capture.PNG

0

Please sign in to leave a comment.