IntelliJ no longer hotswaps my changes - Any idea what's wrong?

Under the Debugger-Hotswap settings I have everything turned on with "Always" to reload classes.

I'm building a Grails 2.0 application.

This used to work for me on a previous grails project.  I don't know if it is related to grails 2.0 or if something has just happened in my environment.

It also doesn't reload even simple changes to .css files or .js files.  The only thing that does work is a change to a gsp file.  That will recompile and reload to the currently running debugging environment.

Any ideas?  This is getting to be pretty painful to me.

I upgraded to the 10.5.4 but that didn't help.

7 comments

Could you attache first line from console, please?
a.png

0

"C:\Program Files\Java\jdk1.6.0_22\bin\java" -agentlib:jdwp=transport=dt_socket,address=127.0.0.1:56310,suspend=y,server=n -Dgrails.home=C:\grails-2.0.0 -Dbase.dir=C:\apps\game "-Dtools.jar=C:\Program Files\Java\jdk1.6.0_22\lib\tools.jar" -Dgroovy.starter.conf=C:\grails-2.0.0/conf/groovy-starter.conf -Xmx1G -Xms356m -XX:MaxPermSize=356m -Djline.WindowsTerminal.directConsole=false -javaagent:C:\Users\aressler\.IntelliJIdea11\system\groovyHotSwap\gragent.jar -Dfile.encoding=windows-1252 -classpath "C:\grails-2.0.0\lib\org.codehaus.groovy\groovy-all\jars\groovy-all-1.8.4.jar;C:\grails-2.0.0\dist\grails-bootstrap-2.0.0.jar;C:\Program Files (x86)\JetBrains\IntelliJ IDEA 11.0\lib\idea_rt.jar" org.codehaus.groovy.grails.cli.support.GrailsStarter --main org.codehaus.groovy.grails.cli.GrailsScriptRunner --conf C:\grails-2.0.0/conf/groovy-starter.conf "-Dserver.port=80 run-app"
Connected to the target VM, address: '127.0.0.1:56310', transport: 'socket'

This seems to be related to using an inline plugin.  I have another project where it still seems to work, but it doesn't have a plugin.

I should add that I have upgraded to both the IntelliJ 11 and the released grails 2.0.0 and I still have the problem.

0

Looks like it's effect of http://youtrack.jetbrains.net/issue/IDEA-78991
"Command line" field in your Grails Run Configuration is "-Dserver.port=80 run-app". You have to move "-Dserver.port=80" to 'VM options' field.

0

I have another grails project that won't hotswap.  It has nothing on the command line but run-app.  So it doesn't seem to be the same problem.  The first project I wrote about still hotswaps fine.

Here is the startup line.

"C:\Program Files\Java\jdk1.6.0_22\bin\java" -agentlib:jdwp=transport=dt_socket,address=127.0.0.1:61859,suspend=y,server=n -Dgrails.home=C:\grails-2.0.0 -Dbase.dir=C:\apps\reportingServer "-Dtools.jar=C:\Program Files\Java\jdk1.6.0_22\lib\tools.jar" -Dgroovy.starter.conf=C:\grails-2.0.0/conf/groovy-starter.conf -Xmx1G -Xms356m -XX:MaxPermSize=356m -Dserver.port=80 -Djline.WindowsTerminal.directConsole=false -javaagent:C:\grails-2.0.0\lib\com.springsource.springloaded\springloaded-core\jars\springloaded-core-1.0.2.jar -noverify -Dspringloaded=profile=grails -Dfile.encoding=windows-1252 -classpath "C:\grails-2.0.0\lib\org.codehaus.groovy\groovy-all\jars\groovy-all-1.8.4.jar;C:\grails-2.0.0\dist\grails-bootstrap-2.0.0.jar;C:\Program Files (x86)\JetBrains\IntelliJ IDEA 11.1.1\lib\idea_rt.jar" org.codehaus.groovy.grails.cli.support.GrailsStarter --main org.codehaus.groovy.grails.cli.GrailsScriptRunner --conf C:\grails-2.0.0/conf/groovy-starter.conf run-app

Any other ideas?

Message was edited by: Andrew Ressler

0

The command line is correct. Does hotswap work when you run application without IDEA?

0

It doesn't.  So I guess this isn't an intellij problem.  Do you happen to have any ideas why thought?

Thanks,

0

I ran into the same problem and found the solution.
See http://devnet.jetbrains.net/thread/439819

Edit <project>\.idea\workspace.xml and make sure the option "dynamic.classpath" is set to false.
At least that did it for me.

-Cedric

0

Please sign in to leave a comment.