Remote deployment to Tomcat

Is it possible to remotely deploy locally built artifacts to a Remote Tomcat? I've been banging my head against the staging and host controls shown in the remote tomcat run configuration but every attempt results in a file transfer window appearing with the message "no files or folders to process"? I'm also confused by the host configuration here as the mapping and exclusions tabs always appear empty. I've tried local mounted folders and SFTP setups, neither seems to want to work.

With my example here I've mounted my remote tomcats webapps folder on Windows as W:\ (with correct tomcat app user)

I know this works fine with a local tomcat server, but I'm trying to test/debug same webapp against Linux. Confused as to how to make this dialog work, or even if it does. Notice I'm building the webapp artifact navigator.webinf, but can't see how to transfer it? ideally as a .war.

Remote Tomcat Run Config:
remote tomcat run config.png
Host settings (Mappings & Exclusions always blank?):
remote tomcat deployment host.png

1 comment
Comment actions Permalink

Hello,

I'm not sure, but probably you've read the instruction on remote staging at http://www.jetbrains.com/idea/webhelp/run-debug-configuration-tomcat.html#example

Some points on your case:

1) you shouldn't use 'webapps' or any other subfolder under Tomcat home for remote staging, but just an empty folder which is accessible by Tomcat user,
so you may create and use 'staging' folder under '/usr/share/', in this case you should:
- mount W: to /usr/share/staging
- set 'Path from root' to '.'
- set 'Mapped as' to '/usr/share/staging'

2) 'Mappings' and 'Excluded paths' tabs are NOT relevant to the remote staging, so they're OK to be empty

3) It's strange that you are receiving 'no files or folders to process' message, it looks like your artifact is empty -- you should try to rebuild the artifact before launching the run configuration,
and ensure that the artifact output directory is not empty.

Regards,
MIchael
1

Please sign in to leave a comment.