Indexing problem with Haxe plugin

Hi,

I'm developing a project with Flash and Haxe modules. When adding a Haxe module to my project, I get

"Cannot run FlexUnit tests while updating indices. Please execute this run configuration again after indices are built."

when trying to run FlexUnit tests.

In detail and to reproduce: I add the Haxe module, select invalidate caches and restart, indexing task finishes, try to run FlexUnit tests, the above error appears. The problem disappears if I drop the Haxe module.

Anyone met or got around this?
Thanks,
Schipy

Specs:
IntelliJ IDEA 11.1.3 Ultimate
haXe Support 0.47
haXe: 2.09

4 comments
Comment actions Permalink

Hello Peter,

Could you please attach idea.log? (Help -> Reveal log in...)

Thanks!
Kirill

0
Comment actions Permalink

Hi Kirill, here's the log starting from adding the Haxe module and then restarting.

Thanks for investigating!
Peter



Attachment(s):
idea.haxe_index.log.zip
0
Comment actions Permalink

Still cannot reproduce and have no idea about the reason... Could you attach screenshots of your Haxe and Flash module settings (especially Dependencies tabs)?

Thanks,
Kirill

0
Comment actions Permalink

Hi,

I found the problem, I had a lot of unnecessary things on source path, including binaries, html reports, non hx sources etc. After exluding them everything is fine.

Thanks for looking into this!
Peter

0

Please sign in to leave a comment.