Idea 11.1.2 and 'Server is not connected. Press 'Deploy' to start deployment.' to default JBoss 6.1 configuration

Hello,
I am struggling with this unfamous problem. I had it previously with other versions of JBoss, but this time I can't solve it.
I am trying to deploy from IDEA the application to fresh and default JBoss 6.1 without any success. I am able to do this with JBoss 4.3.2.
I was looking around the web, this forum and YouTruck for any solution and I tried these:

  • add -d64 option
  • add -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.KQueueSelectorProvider option
  • disable firewall
  • add -b 0.0.0.0 option
  • add to JAVA_OPTS option: PRESERVE_JAVA_OPTS=true
  • restart laptop ;]


Unfortunatelly I am unable to deploy application at all.
Below are my startup informaction. I didn't change any JBoss configuration at all. Just tried to run it from IDEA.

Mac 10.7.4
IDEA 11.1.2
Java 1.6.0_33


/Users/lgr/Tools/misio-jboss-6.1.0/bin/run.sh -c jbossweb-standalone
[2012-07-24 03:59:42,553] Artifact netiacc-frontend:war: Server is not connected. Press 'Deploy' to start deployment.
=========================================================================

  JBoss Bootstrap Environment

  JBOSS_HOME: /Users/lgr/Tools/misio-jboss-6.1.0

  JAVA: /Library/Java/Home/bin/java

  JAVA_OPTS: -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.KQueueSelectorProvider -d64  -Dprogram.name=run.sh -Dlogging.configuration=file:/Users/lgr/Tools/misio-jboss-6.1.0/bin/logging.properties -Djava.library.path=/Users/lgr/Tools/misio-jboss-6.1.0/bin/native/lib64

  CLASSPATH: /Users/lgr/Tools/misio-jboss-6.1.0/bin/run.jar

=========================================================================

15:59:43,306 INFO  [AbstractJBossASServerBase] Server Configuration:

     JBOSS_HOME URL: file:/Users/lgr/Tools/misio-jboss-6.1.0/
     Bootstrap: $JBOSS_HOME/server/jbossweb-standalone/conf/bootstrap.xml
     Common Base: $JBOSS_HOME/common/
     Common Library: $JBOSS_HOME/common/lib/
     Server Name: jbossweb-standalone
     Server Base: $JBOSS_HOME/server/
     Server Library: $JBOSS_HOME/server/jbossweb-standalone/lib/
     Server Config: $JBOSS_HOME/server/jbossweb-standalone/conf/
     Server Home: $JBOSS_HOME/server/jbossweb-standalone/
     Server Data: $JBOSS_HOME/server/jbossweb-standalone/data/
     Server Log: $JBOSS_HOME/server/jbossweb-standalone/log/
     Server Temp: $JBOSS_HOME/server/jbossweb-standalone/tmp/

15:59:43,309 INFO  [AbstractServer] Starting: JBossAS [6.1.0.Final "Neo"]
15:59:44,802 INFO  [ServerInfo] Java version: 1.6.0_33,Apple Inc.
15:59:44,802 INFO  [ServerInfo] Java Runtime: Java(TM) SE Runtime Environment (build 1.6.0_33-b03-424-11M3720)
15:59:44,802 INFO  [ServerInfo] Java VM: Java HotSpot(TM) 64-Bit Server VM 20.8-b03-424,Apple Inc.
15:59:44,802 INFO  [ServerInfo] OS-System: Mac OS X 10.7.4,x86_64
15:59:44,804 INFO  [ServerInfo] VM arguments: -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.KQueueSelectorProvider -Dprogram.name=run.sh -Dlogging.configuration=file:/Users/lgr/Tools/misio-jboss-6.1.0/bin/logging.properties -Djava.library.path=/Users/lgr/Tools/misio-jboss-6.1.0/bin/native/lib64 -Djava.endorsed.dirs=/Users/lgr/Tools/misio-jboss-6.1.0/lib/endorsed
15:59:44,846 INFO  [JMXKernel] Legacy JMX core initialized
15:59:48,832 INFO  [AprLifecycleListener] The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /Users/lgr/Tools/misio-jboss-6.1.0/bin/native/lib64
15:59:49,132 INFO  [JMXConnector] starting JMXConnector on host 127.0.0.1:1090
15:59:49,395 INFO  [WebService] Using RMI server codebase: http://127.0.0.1:8083/
15:59:49,514 INFO  [TomcatDeployment] deploy, ctxPath=/
15:59:49,720 INFO  [service] Removing bootstrap log handlers
15:59:49,787 INFO  [org.apache.coyote.http11.Http11Protocol] Starting Coyote HTTP/1.1 on http-127.0.0.1-8080
15:59:49,790 INFO  [org.apache.coyote.ajp.AjpProtocol] Starting Coyote AJP/1.3 on ajp-127.0.0.1-8009
15:59:49,790 INFO  [org.jboss.bootstrap.impl.base.server.AbstractServer] JBossAS [6.1.0.Final "Neo"] Started in 6s:477ms



Please help me to solve this problem, because I cannot simply do my work :/ And of course let me know what can I do to help you investigate it. Thank you.

UPDATE
I found out it doesn't work when I have chosen server instance 'standalone'. With 'default' I get 'Server is not connected. Press 'Deploy' to start deployment.' at the very beginning, but the application is deploying.
Can someone explain why is this happening?

Please sign in to leave a comment.