Autocomplete not working

Got a couple projects I'm working at the minute one PHP and one actionsctipt. Was having no porblems at all, everything was working great. Then one day I just couldn't get auto complete working, I can get some classes but then other just dont appear, I can see them all listed in the external libraries tree.

I have tried restarting, nothing, removing the libraries and adding them again, nothing, recreating the project, nothing, creating a new project, nothing.

Really have no idea whats going on/happened.

I am running version 11.1.1 with PHP plugin version 117.694. The PHP plugin was updated today, but it was happening on the previous version and updating hasn't helped.

5 comments
Comment actions Permalink

Hi Daniel,

Have you tried "File | Invalidate caches ..." ?

0
Comment actions Permalink

Thanks for the reply.

Just tried and it worked a treat on the actionscript project but still on the PHP project getting nothing.

0
Comment actions Permalink

Anyone else have any suggestions?

0
Comment actions Permalink

Hi,

If original suggestion helped .. then only other thing I can suggest is to try and delete ALL cache/index folders manually. Please refer to this document for such folder locations: http://devnet.jetbrains.net/docs/DOC-181 . On Windows 7 such folder would  typically be located at C:\Users\USERNAME\.IntelliJIdeaXX\system

Another way of doing the same (don't know if it works like that on non-Windows OS):

  • backup your ide-wide config (manually .. or via official "File | Export Settings...")
  • uninstall IDEA completely
  • install it again
  • restore previously saved settings
0
Comment actions Permalink

Thank @Andriy Bazanov. It works for me.

0

Please sign in to leave a comment.