IDEA 5.1.2 does NOT support VSS.2005?

Hi,
IDEA 5.1.2 can not check out/in files using VSS 2005, does IDEA 5.1.2 not support VSS 2005?

Thanks

5 comments

Hello truecolor,

t> Hi, IDEA 5.1.2 can not check out/in files using VSS 2005, does IDEA
t> 5.1.2 not support VSS 2005?

It does not. In fact Visual SourceSafe 2005 was released after IntelliJ IDEA
5.1.2.

--
Dmitry Jemerov
Software Developer
http://www.jetbrains.com/
"Develop with Pleasure!"


0

so, will IDEA 6.0 support the VSS2005?

0

Hello truecolor,

t> so, will IDEA 6.0 support the VSS2005?

Yes, either 6.0 or one of the bugfix updates (6.0.x) will support VSS 2005.

--
Dmitry Jemerov
Software Developer
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Thanks.

btw:

I find there are some problems using VSS in 5..1.2.

The case is like this:

check out files by IDEA, then check in files by VSS client;

or the other case:
check out files by VSS client, then check in files by IDEA.

in these cases, sometime the color of the files name can not be updated in IDEA .

0

Hi,

I recently changed company, and am trying to convince them to switch IDE (they've recently standardised on Eclipse). The major barrier at this time is their use of Visual Source Safe 2005.

I'm not an expert on VSS, but it works here via the VSS plug-in for Eclipse. There is a particular configuration issue here that might prevent compatibility (I'm guessing this from the options available in the VSS plugin for IDEA 5.1.2, which doesn't seem to support this option...). Basically, starting the VSS client from the icon in the Windows Start menu doesn't work, so for each repository (I must work with at least two, the "core" and the "departmental application" built around the core), we create a shortcut icon and change the target to add "/DREPOSITORY", as shown:

"C:\Program Files\Microsoft Visual SourceSafe\ssexp.exe" /DPORTAL
"C:\Program Files\Microsoft Visual SourceSafe\ssexp.exe" /DVOLCANO

There are different users defined in each repository.

There are other compelling reasons that I could use to convince them to switch (especially as they're switching to use AJAX development, where Eclipse is very clumsy), but this is a blocker, as with around 50 developers I can't impose a switch to Subversion or CVS.

Please advise me if this is in fact supported or if I can hope that this will work in IDEA 6. Using Eclipse for web development is not very enjoyable...

Thanks,
Chris

0

Please sign in to leave a comment.