Debugging of Flexunit tests not working

I am using IntelliJ 11.1.2. I can debug my Flex application without any problem, but not so for FlexUnit tests.

The tests run in normal mode and in debug mode, but IntelliJ never stops at any breakpoint (where that works perfectly in my application). Any idea what is wrong? The unit test is in an SWC module if that matters and I run it on Mac OS X 10.7.4.

regards,

Wim

5 comments
Comment actions Permalink

Most probably test runner is compiled without debug information. Check 'Compiler Options' tab of the corresponding build configuration.

0
Comment actions Permalink

I checked the Compiler Options tab (in Project Structure > Modules > (my module) ), but 'Generate debuggable SWC' is checked. Any other ideas?

0
Comment actions Permalink

Found the problem. I had to update my flex-mojos configuration to include <debug>true</debug> and re-import the maven config. The strange thing is that the UI of the compiler options in IntelliJ does not seem to indicate a change (the checkbox is still checked), but at least the debugger stops now.

0
Comment actions Permalink

Compiler Options tab has the warning that additional compiler config file and additional compiler options may override options set in the table.
I think we'll implement http://youtrack.jetbrains.com/issue/IDEA-84009 and will force -debug=true when you press Debug button.

0
Comment actions Permalink

Would indeed be great to force debug! Thx for helping me out.

0

Please sign in to leave a comment.