Ant Execute After Compilation

I added an ant target to be executed after compilation but I can't find a way to turn that off. Have I missed something or is this a bug in 5594?

6 comments
Comment actions Permalink

Hello Glen,

GS> I added an ant target to be executed after compilation but I can't
GS> find a way to turn that off. Have I missed something or is this a
GS> bug in 5594?

There's a checkbox for this in the run configuration editor. Does it work
for you?

--
Dmitry Jemerov
Software Developer
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Yes. I hadn't noticed that before. What I was expecting was that you could uncheck the option by right clicking on the target navigating to Execute On then unchecking the Run Before/After menu item. It would be nice to have it in both places or maybe to get rid of that menu altogether.

One other question. My ant file uses the import task to import standard built features. Unfortunately the imported targets do not show up in the sidebar. Is there a way to configure things so that these targets appear in the sidebar?

0
Comment actions Permalink

Hello Glen,

GS> One other question. My ant file uses the import task to import
GS> standard built features. Unfortunately the imported targets do not
GS> show up in the sidebar. Is there a way to configure things so that
GS> these targets appear in the sidebar?

As far as I remember, this is fixed in build 5594.

--
Dmitry Jemerov
Software Developer
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hello Glen,

GS> One other question. My ant file uses the import task to import
GS> standard built features. Unfortunately the imported targets do not
GS> show up in the sidebar. Is there a way to configure things so that
GS> these targets appear in the sidebar?

As far as I remember, this is fixed in build 5594.


Seems not to work for me. I use the following mechanism to include my files

]]>

I tried replacing to prop with the value inline but that didn't help either.

0
Comment actions Permalink

Yes. I hadn't noticed that before. What I was
expecting was that you could uncheck the option by
right clicking on the target navigating to Execute On
then unchecking the Run Before/After menu item. It
would be nice to have it in both places or maybe to
get rid of that menu altogether.


Actually after trying this I found that even after modifying the setting in the configurations dialog it still ends up calling out to ant even though "Run ant target" is unchecked.

0
Comment actions Permalink

Follow up questions not answered

0

Please sign in to leave a comment.